CVE-2018-6140
CVE-2018-6140
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Allowing the chrome.debugger API to attach to Web UI pages in DevTools in Google Chrome prior to 67.0.3396.62 allowed an attacker who convinced a user to install a malicious extension to execute arbitrary code via a crafted Chrome Extension.
CVSS 8.8 · High · EPSS 2.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
chrome
- Versions
- ≥ unspecified, < 67.0.3396.62: Affected (custom)
Update to 67.0.3396.62
chromium-browser Ubuntu:16.04:LTS
- Versions
- 45.0.2454.101-0ubuntu1.1201
- 47.0.2526.73-0ubuntu1.1218
- 47.0.2526.106-0ubuntu1.1221
- 48.0.2564.82-0ubuntu1.1222
- 48.0.2564.116-0ubuntu1.1229
- 49.0.2623.87-0ubuntu1.1232
- 49.0.2623.108-0ubuntu1.1233
- 50.0.2661.102-0ubuntu0.16.04.1.1237
- 51.0.2704.79-0ubuntu0.16.04.1.1242
- 52.0.2743.116-0ubuntu0.16.04.1.1250
- 53.0.2785.143-0ubuntu0.16.04.1.1254
- 53.0.2785.143-0ubuntu0.16.04.1.1257
- 55.0.2883.87-0ubuntu0.16.04.1263
- 56.0.2924.76-0ubuntu0.16.04.1268
- 57.0.2987.98-0ubuntu0.16.04.1276
- 58.0.3029.81-0ubuntu0.16.04.1277
- 58.0.3029.96-0ubuntu0.16.04.1279
- 58.0.3029.110-0ubuntu0.16.04.1281
- 59.0.3071.109-0ubuntu0.16.04.1289
- 59.0.3071.109-0ubuntu0.16.04.1291
- 60.0.3112.78-0ubuntu0.16.04.1293
- 60.0.3112.113-0ubuntu0.16.04.1298
- 61.0.3163.79-0ubuntu0.16.04.1300
- 61.0.3163.100-0ubuntu0.16.04.1306
- 62.0.3202.62-0ubuntu0.16.04.1308
- 62.0.3202.75-0ubuntu0.16.04.1313
- 62.0.3202.89-0ubuntu0.16.04.1315
- 62.0.3202.94-0ubuntu0.16.04.1317
- 63.0.3239.84-0ubuntu0.16.04.1
- 63.0.3239.132-0ubuntu0.16.04.1
- 64.0.3282.119-0ubuntu0.16.04.1
- 64.0.3282.140-0ubuntu0.16.04.1
- 64.0.3282.167-0ubuntu0.16.04.1
- 65.0.3325.181-0ubuntu0.16.04.1
- 66.0.3359.139-0ubuntu0.16.04.3
- 66.0.3359.181-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 67.0.3396.99-0ubuntu0.16.04.2
Update to 67.0.3396.99-0ubuntu0.16.04.2
oxide-qt Ubuntu:16.04:LTS
- Versions
- 1.9.5-0ubuntu1
- 1.10.3-0ubuntu0.15.10.1
- 1.10.3-0ubuntu0.15.10.2
- 1.11.3-0ubuntu3
- 1.11.4-0ubuntu1
- 1.11.5-0ubuntu1
- 1.12.5-0ubuntu1
- 1.12.6-0ubuntu1
- 1.12.7-0ubuntu1
- 1.13.6-0ubuntu1
- 1.14.7-0ubuntu1
- 1.14.9-0ubuntu0.16.04.1
- 1.15.7-0ubuntu0.16.04.1
- 1.15.8-0ubuntu0.16.04.1
- 1.16.5-0ubuntu0.16.04.1
- 1.17.7-0ubuntu0.16.04.1
- 1.17.9-0ubuntu0.16.04.1
- 1.18.3-0ubuntu0.16.04.1
- 1.18.5-0ubuntu0.16.04.1
- 1.19.4-0ubuntu0.16.04.1
- 1.20.4-0ubuntu0.16.04.1
- 1.21.5-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
chromium-browser Ubuntu:18.04:LTS
- Versions
- 61.0.3163.100-0ubuntu1.1378
- 62.0.3202.62-0ubuntu0.17.10.1380
- 62.0.3202.89-0ubuntu1.1386
- 62.0.3202.94-0ubuntu1.1388
- 63.0.3239.84-0ubuntu1
- 63.0.3239.108-0ubuntu1
- 64.0.3282.119-0ubuntu1
- 64.0.3282.140-0ubuntu1
- 64.0.3282.167-0ubuntu1
- 65.0.3325.146-0ubuntu1
- 65.0.3325.181-0ubuntu1
- 66.0.3359.139-0ubuntu0.18.04.3
- 66.0.3359.181-0ubuntu0.18.04.1
- Affected ranges
- ECOSYSTEM: < 67.0.3396.99-0ubuntu0.18.04.1
Update to 67.0.3396.99-0ubuntu0.18.04.1
Original sources
- http://www.securityfocus.com/bid/104309
- https://chromereleases.googleblog.com/2018/05/stable-channel-update-for-desktop_58.html
- http://www.securitytracker.com/id/1041014
- https://access.redhat.com/errata/RHSA-2018:1815
- https://crbug.com/798222
- https://www.debian.org/security/2018/dsa-4237
- https://nvd.nist.gov/vuln/detail/CVE-2018-6140