CVE-2018-6307
CVE-2018-6307
This page contains facts from public vulnerability sources. Check the original advisory before updating.
LibVNC before commit ca2a5ac02fbbadd0a21fabba779c1ea69173d10b contains heap use-after-free vulnerability in server code of file transfer extension that can result remote code execution.
CVSS 8.1 · High · EPSS 26.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
libvnc
- Versions
- commit ca2a5ac02fbbadd0a21fabba779c1ea69173d10b: Affected
No fix published
libvncserver Debian:12
- Affected ranges
- ECOSYSTEM: < 0.9.11+dfsg-1.2
Update to 0.9.11+dfsg-1.2
libvncserver Debian:13
- Affected ranges
- ECOSYSTEM: < 0.9.11+dfsg-1.2
Update to 0.9.11+dfsg-1.2
libvncserver Debian:14
- Affected ranges
- ECOSYSTEM: < 0.9.11+dfsg-1.2
Update to 0.9.11+dfsg-1.2
libvncserver Ubuntu:14.04:LTS
- Versions
- 0.9.9+dfsg-1
- 0.9.9+dfsg-1ubuntu1
- 0.9.9+dfsg-1ubuntu1.1
- 0.9.9+dfsg-1ubuntu1.2
- 0.9.9+dfsg-1ubuntu1.3
- Affected ranges
- ECOSYSTEM: < 0.9.9+dfsg-1ubuntu1.4
Update to 0.9.9+dfsg-1ubuntu1.4
libvncserver Ubuntu:16.04:LTS
- Versions
- 0.9.10+dfsg-3
- 0.9.10+dfsg-3build1
- 0.9.10+dfsg-3ubuntu0.16.04.1
- 0.9.10+dfsg-3ubuntu0.16.04.2
- Affected ranges
- ECOSYSTEM: < 0.9.10+dfsg-3ubuntu0.16.04.3
Update to 0.9.10+dfsg-3ubuntu0.16.04.3
libvncserver Ubuntu:18.04:LTS
- Versions
- 0.9.11+dfsg-1
- 0.9.11+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 0.9.11+dfsg-1ubuntu1.1
Update to 0.9.11+dfsg-1ubuntu1.1
Original sources
- https://ics-cert.kaspersky.com/advisories/klcert-advisories/2018/12/19/klcert-18-026-libvnc-heap-use-after-free/
- https://www.debian.org/security/2019/dsa-4383
- https://lists.debian.org/debian-lts-announce/2018/12/msg00017.html
- https://usn.ubuntu.com/3877-1/
- https://lists.debian.org/debian-lts-announce/2019/10/msg00042.html
- https://nvd.nist.gov/vuln/detail/CVE-2018-6307