p PatchFirst

CVE-2018-7183

CVE-2018-7183

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Buffer overflow in the decodearr function in ntpq in ntp 4.2.8p6 through 4.2.8p10 allows remote attackers to execute arbitrary code by leveraging an ntpq query and sending a response with a crafted array.

CVSS 9.8 · Critical · EPSS 10.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ntp Debian:11

    Affected ranges
    • ECOSYSTEM: < 1:4.2.8p11+dfsg-1

    Update to 1:4.2.8p11+dfsg-1

  • ntp Ubuntu:14.04:LTS

    Versions
    • 1:4.2.6.p5+dfsg-3ubuntu2
    • 1:4.2.6.p5+dfsg-3ubuntu2.14.04.1
    • 1:4.2.6.p5+dfsg-3ubuntu2.14.04.2
    • 1:4.2.6.p5+dfsg-3ubuntu2.14.04.3
    • 1:4.2.6.p5+dfsg-3ubuntu2.14.04.5
    • 1:4.2.6.p5+dfsg-3ubuntu2.14.04.6
    • 1:4.2.6.p5+dfsg-3ubuntu2.14.04.7
    • 1:4.2.6.p5+dfsg-3ubuntu2.14.04.8
    • 1:4.2.6.p5+dfsg-3ubuntu2.14.04.10
    • 1:4.2.6.p5+dfsg-3ubuntu2.14.04.11
    • 1:4.2.6.p5+dfsg-3ubuntu2.14.04.12
    Affected ranges
    • ECOSYSTEM: < 1:4.2.6.p5+dfsg-3ubuntu2.14.04.13

    Update to 1:4.2.6.p5+dfsg-3ubuntu2.14.04.13

  • ntp Ubuntu:16.04:LTS

    Versions
    • 1:4.2.6.p5+dfsg-3ubuntu8
    • 1:4.2.6.p5+dfsg-3ubuntu8.1
    • 1:4.2.6.p5+dfsg-3ubuntu9
    • 1:4.2.8p4+dfsg-3ubuntu1
    • 1:4.2.8p4+dfsg-3ubuntu2
    • 1:4.2.8p4+dfsg-3ubuntu3
    • 1:4.2.8p4+dfsg-3ubuntu4
    • 1:4.2.8p4+dfsg-3ubuntu5
    • 1:4.2.8p4+dfsg-3ubuntu5.1
    • 1:4.2.8p4+dfsg-3ubuntu5.2
    • 1:4.2.8p4+dfsg-3ubuntu5.3
    • 1:4.2.8p4+dfsg-3ubuntu5.4
    • 1:4.2.8p4+dfsg-3ubuntu5.5
    • 1:4.2.8p4+dfsg-3ubuntu5.6
    • 1:4.2.8p4+dfsg-3ubuntu5.7
    • 1:4.2.8p4+dfsg-3ubuntu5.8
    Affected ranges
    • ECOSYSTEM: < 1:4.2.8p4+dfsg-3ubuntu5.9

    Update to 1:4.2.8p4+dfsg-3ubuntu5.9

  • ntp Ubuntu:18.04:LTS

    Versions
    • 1:4.2.8p10+dfsg-5ubuntu3
    • 1:4.2.8p10+dfsg-5ubuntu4
    • 1:4.2.8p10+dfsg-5ubuntu5
    • 1:4.2.8p10+dfsg-5ubuntu6
    • 1:4.2.8p10+dfsg-5ubuntu7
    Affected ranges
    • ECOSYSTEM: < 1:4.2.8p10+dfsg-5ubuntu7.1

    Update to 1:4.2.8p10+dfsg-5ubuntu7.1

Original sources

Check your server →