CVE-2018-7417
CVE-2018-7417
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Wireshark 2.2.0 to 2.2.12 and 2.4.0 to 2.4.4, the IPMI dissector could crash. This was addressed in epan/dissectors/packet-ipmi-picmg.c by adding support for crafted packets that lack an IPMI header.
CVSS 7.5 · High · EPSS 2.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wireshark Debian:12
- Affected ranges
- ECOSYSTEM: < 2.4.5-1
Update to 2.4.5-1
wireshark Debian:13
- Affected ranges
- ECOSYSTEM: < 2.4.5-1
Update to 2.4.5-1
wireshark Debian:14
- Affected ranges
- ECOSYSTEM: < 2.4.5-1
Update to 2.4.5-1
wireshark Ubuntu:14.04:LTS
- Versions
- 1.10.2-1
- 1.10.3-1
- 1.10.5-1ubuntu1
- 1.10.5-2
- 1.10.6-1
- 1.12.1+g01b65bf-4+deb8u11ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 2.6.3-1~ubuntu14.04.1
Update to 2.6.3-1~ubuntu14.04.1
wireshark Ubuntu:16.04:LTS
- Versions
- 1.12.7+g7fc8978-1
- 1.12.8+g5b6e543-2
- 2.0.1+g59ea380-3build1
- 2.0.2+ga16e22e-1
- 2.2.6+g32dac6a-2ubuntu0.16.04
- Affected ranges
- ECOSYSTEM: < 2.6.3-1~ubuntu16.04.1
Update to 2.6.3-1~ubuntu16.04.1
wireshark Ubuntu:18.04:LTS
- Versions
- 2.4.2-1
- 2.4.3-1
- 2.4.4-1
- 2.4.5-1
- Affected ranges
- ECOSYSTEM: < 2.6.3-1~ubuntu18.04.1
Update to 2.6.3-1~ubuntu18.04.1
Original sources
- https://lists.debian.org/debian-lts-announce/2018/04/msg00018.html
- https://code.wireshark.org/review/gitweb?p=wireshark.git%3Ba=commit%3Bh=81216a176b25dd8a616e11808a951e141a467009
- https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=14409
- https://lists.debian.org/debian-lts-announce/2019/01/msg00010.html
- http://www.securityfocus.com/bid/103156
- https://www.wireshark.org/security/wnpa-sec-2018-12.html
- https://nvd.nist.gov/vuln/detail/CVE-2018-7417