CVE-2018-7600
CVE-2018-7600
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 allows remote attackers to execute arbitrary code because of an issue affecting multiple subsystems with default or common module configurations.
CVSS 9.8 · Critical · EPSS 100.0% · In KEV · Public exploit · Fix available
- Published
- Updated
Affected products and versions
drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1
- Versions
- Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1: Affected
No fix published
drupal/core Packagist
- Versions
- 8.0.0
- 8.0.1
- 8.0.2
- 8.0.3
- 8.0.4
- 8.0.5
- 8.0.6
- 8.1.0
- 8.1.0-beta1
- 8.1.0-beta2
- 8.1.0-rc1
- 8.1.1
- 8.1.10
- 8.1.2
- 8.1.3
- 8.1.4
- 8.1.5
- 8.1.6
- 8.1.7
- 8.1.8
- 8.1.9
- 8.2.0
- 8.2.0-beta1
- 8.2.0-beta2
- 8.2.0-beta3
- 8.2.0-rc1
- 8.2.0-rc2
- 8.2.1
- 8.2.2
- 8.2.3
- 8.2.4
- 8.2.5
- 8.2.6
- 8.2.7
- 8.2.8
- 8.3.0
- 8.3.0-alpha1
- 8.3.0-beta1
- 8.3.0-rc1
- 8.3.0-rc2
- 8.3.1
- 8.3.2
- 8.3.3
- 8.3.4
- 8.3.5
- 8.3.6
- 8.3.7
- 8.3.8
- 8.4.0
- 8.4.1
- 8.4.2
- 8.4.3
- 8.4.4
- 8.4.5
- 8.5.0
- Affected ranges
- ECOSYSTEM: ≥ 8.0.0, < 8.3.9
- ECOSYSTEM: ≥ 8.4.0, < 8.4.6
- ECOSYSTEM: ≥ 8.5.0, < 8.5.1
Update to 8.3.9; Update to 8.4.6; Update to 8.5.1
drupal/core Packagist
- Affected ranges
- ECOSYSTEM: ≥ 7.0, < 7.58
Update to 7.58
drupal/core Packagist
- Versions
- 8.0.0
- 8.0.0-beta10
- 8.0.0-beta11
- 8.0.0-beta12
- 8.0.0-beta13
- 8.0.0-beta14
- 8.0.0-beta15
- 8.0.0-beta16
- 8.0.0-beta6
- 8.0.0-beta7
- 8.0.0-beta8
- 8.0.0-beta9
- 8.0.0-rc1
- 8.0.0-rc2
- 8.0.0-rc3
- 8.0.0-rc4
- 8.0.1
- 8.0.2
- 8.0.3
- 8.0.4
- 8.0.5
- 8.0.6
- 8.1.0
- 8.1.0-beta1
- 8.1.0-beta2
- 8.1.0-rc1
- 8.1.1
- 8.1.10
- 8.1.2
- 8.1.3
- 8.1.4
- 8.1.5
- 8.1.6
- 8.1.7
- 8.1.8
- 8.1.9
- 8.2.0
- 8.2.0-beta1
- 8.2.0-beta2
- 8.2.0-beta3
- 8.2.0-rc1
- 8.2.0-rc2
- 8.2.1
- 8.2.2
- 8.2.3
- 8.2.4
- 8.2.5
- 8.2.6
- 8.2.7
- 8.2.8
- 8.3.0
- 8.3.0-alpha1
- 8.3.0-beta1
- 8.3.0-rc1
- 8.3.0-rc2
- 8.3.1
- 8.3.2
- 8.3.3
- 8.3.4
- 8.3.5
- 8.3.6
- 8.3.7
- 8.3.8
- Affected ranges
- ECOSYSTEM: ≥ 8.0, < 8.3.9
Update to 8.3.9
drupal/core Packagist
- Versions
- 8.4.0
- 8.4.1
- 8.4.2
- 8.4.3
- 8.4.4
- 8.4.5
- Affected ranges
- ECOSYSTEM: ≥ 8.4.0, < 8.4.6
Update to 8.4.6
drupal/core Packagist
- Versions
- 8.5.0
- Affected ranges
- ECOSYSTEM: ≥ 8.5.0, < 8.5.1
Update to 8.5.1
drupal/drupal Packagist
- Affected ranges
- ECOSYSTEM: ≥ 7.0, < 7.58
Update to 7.58
drupal/drupal Packagist
- Versions
- 8.0.0
- 8.0.0-alpha14
- 8.0.0-alpha15
- 8.0.0-beta1
- 8.0.0-beta10
- 8.0.0-beta11
- 8.0.0-beta12
- 8.0.0-beta13
- 8.0.0-beta14
- 8.0.0-beta15
- 8.0.0-beta16
- 8.0.0-beta2
- 8.0.0-beta3
- 8.0.0-beta4
- 8.0.0-beta5
- 8.0.0-beta6
- 8.0.0-beta7
- 8.0.0-beta9
- 8.0.0-rc1
- 8.0.0-rc2
- 8.0.0-rc3
- 8.0.0-rc4
- 8.0.1
- 8.0.2
- 8.0.3
- 8.0.4
- 8.0.5
- 8.0.6
- 8.1.0
- 8.1.0-beta1
- 8.1.0-beta2
- 8.1.0-rc1
- 8.1.1
- 8.1.10
- 8.1.2
- 8.1.3
- 8.1.4
- 8.1.5
- 8.1.6
- 8.1.7
- 8.1.8
- 8.1.9
- 8.2.0
- 8.2.0-beta1
- 8.2.0-beta2
- 8.2.0-beta3
- 8.2.0-rc1
- 8.2.0-rc2
- 8.2.1
- 8.2.2
- 8.2.3
- 8.2.4
- 8.2.5
- 8.2.6
- 8.2.7
- 8.2.8
- 8.3.0
- 8.3.0-alpha1
- 8.3.0-beta1
- 8.3.0-rc1
- 8.3.0-rc2
- 8.3.1
- 8.3.2
- 8.3.3
- 8.3.4
- 8.3.5
- 8.3.6
- 8.3.7
- 8.3.8
- Affected ranges
- ECOSYSTEM: ≥ 8.0, < 8.3.9
Update to 8.3.9
drupal/drupal Packagist
- Versions
- 8.4.0
- 8.4.0-alpha1
- 8.4.0-beta1
- 8.4.0-rc1
- 8.4.0-rc2
- 8.4.1
- 8.4.2
- 8.4.3
- 8.4.4
- 8.4.5
- Affected ranges
- ECOSYSTEM: ≥ 8.4, < 8.4.6
Update to 8.4.6
drupal/drupal Packagist
- Versions
- 8.5.0
- 8.5.0-alpha1
- 8.5.0-beta1
- 8.5.0-rc1
- Affected ranges
- ECOSYSTEM: ≥ 8.5, < 8.5.1
Update to 8.5.1
drupal7 Ubuntu:Pro:14.04:LTS
- Versions
- 7.23-1
- 7.24-1
- 7.24-2
- 7.26-1
- 7.26-1ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 7.26-1ubuntu0.1+esm1
Update to 7.26-1ubuntu0.1+esm1
drupal7 Ubuntu:Pro:16.04:LTS
- Versions
- 7.38-1
- 7.41-1
- 7.44-1ubuntu1~16.04.0
- Affected ranges
- ECOSYSTEM: < 7.44-1ubuntu1~16.04.0+esm1
Update to 7.44-1ubuntu1~16.04.0+esm1
Original sources
- https://github.com/g0rx/CVE-2018-7600-Drupal-RCE
- http://www.securitytracker.com/id/1040598
- https://twitter.com/arancaytar/status/979090719003627521
- https://twitter.com/RicterZ/status/979567469726613504
- https://www.drupal.org/sa-core-2018-002
- https://www.synology.com/support/security/Synology_SA_18_17
- https://github.com/a2u/CVE-2018-7600
- https://www.exploit-db.com/exploits/44482/
- https://research.checkpoint.com/uncovering-drupalgeddon-2/
- https://groups.drupal.org/security/faq-2018-002
- https://www.debian.org/security/2018/dsa-4156
- https://lists.debian.org/debian-lts-announce/2018/03/msg00028.html
- https://www.exploit-db.com/exploits/44448/
- http://www.securityfocus.com/bid/103534
- https://badpackets.net/over-100000-drupal-websites-vulnerable-to-drupalgeddon-2-cve-2018-7600/
- https://greysec.net/showthread.php?tid=2912&pid=10561
- https://blog.appsecco.com/remote-code-execution-with-drupal-core-sa-core-2018-002-95e6ecc0c714
- https://www.tenable.com/blog/critical-drupal-core-vulnerability-what-you-need-to-know
- https://twitter.com/RicterZ/status/984495201354854401
- https://www.exploit-db.com/exploits/44449/
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2018-7600
- https://nvd.nist.gov/vuln/detail/CVE-2018-7600