CVE-2018-8021
CVE-2018-8021
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Versions of Superset prior to 0.23 used an unsafe load method from the pickle library to deserialize data leading to possible remote code execution. Note Superset 0.23 was released prior to any Superset release under the Apache Software Foundation.
CVSS 9.8 · Critical · EPSS 53.4% · Public exploit · Fix available
- Published
- Updated
Stack: python
Affected products and versions
superset
- Versions
- prior to 0.23: Affected
No fix published
superset PyPI
- Versions
- 0.13.2
- 0.14.0
- 0.14.1
- 0.15.0
- 0.15.1
- 0.15.3
- 0.15.4
- 0.17.0
- 0.17.1
- 0.17.2
- 0.17.3
- 0.17.4
- 0.17.5
- 0.17.6
- 0.18.0
- 0.18.2
- 0.18.3
- 0.18.4
- 0.18.5
- 0.19.0
- 0.19.1
- 0.20.0
- 0.20.1
- 0.20.2
- 0.20.3
- 0.20.4
- 0.20.5
- 0.20.6
- 0.21.0
- 0.21.1
- 0.22.0
- 0.22.1
- Affected ranges
- ECOSYSTEM: < 0.23
Update to 0.23
superset PyPI
- Versions
- 0.13.2
- 0.14.0
- 0.14.1
- 0.15.0
- 0.15.1
- 0.15.3
- 0.15.4
- 0.17.0
- 0.17.1
- 0.17.2
- 0.17.3
- 0.17.4
- 0.17.5
- 0.17.6
- 0.18.0
- 0.18.2
- 0.18.3
- 0.18.4
- 0.18.5
- 0.19.0
- 0.19.1
- 0.20.0
- 0.20.1
- 0.20.2
- 0.20.3
- 0.20.4
- 0.20.5
- 0.20.6
- 0.21.0
- 0.21.1
- 0.22.0
- 0.22.1
- Affected ranges
- ECOSYSTEM: < 0.23.0
Update to 0.23.0