CVE-2018-8099
CVE-2018-8099
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Incorrect returning of an error code in the index.c:read_entry() function leads to a double free in libgit2 before v0.26.2, which allows an attacker to cause a denial of service via a crafted repository index file.
CVSS 6.5 · Medium · EPSS 1.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
libgit2 Debian:12
- Affected ranges
- ECOSYSTEM: < 0.27.0+dfsg.1-0.6
Update to 0.27.0+dfsg.1-0.6
libgit2 Debian:13
- Affected ranges
- ECOSYSTEM: < 0.27.0+dfsg.1-0.6
Update to 0.27.0+dfsg.1-0.6
libgit2 Debian:14
- Affected ranges
- ECOSYSTEM: < 0.27.0+dfsg.1-0.6
Update to 0.27.0+dfsg.1-0.6
libgit2 Ubuntu:Pro:14.04:LTS
- Versions
- 0.19.0-2
- 0.19.0-2ubuntu0.4
- 0.19.0-2ubuntu0.4+esm1
- Affected ranges
- ECOSYSTEM: < 0.19.0-2ubuntu0.4+esm2
Update to 0.19.0-2ubuntu0.4+esm2
libgit2 Ubuntu:Pro:16.04:LTS
- Versions
- 0.22.2-2
- 0.23.1-1
- 0.24.1-2
- 0.24.1-2ubuntu0.2
- 0.24.1-2ubuntu0.2+esm1
- 0.24.1-2ubuntu0.2+esm2
- Affected ranges
- ECOSYSTEM: < 0.24.1-2ubuntu0.2+esm3
Update to 0.24.1-2ubuntu0.2+esm3
libgit2 Ubuntu:Pro:18.04:LTS
- Versions
- 0.25.1+really0.24.6-1
- 0.26.0+dfsg.1-1.1
- 0.26.0+dfsg.1-1.1build1
- 0.26.0+dfsg.1-1.1ubuntu0.2
- 0.26.0+dfsg.1-1.1ubuntu0.2+esm1
- Affected ranges
- ECOSYSTEM: < 0.26.0+dfsg.1-1.1ubuntu0.2+esm2
Update to 0.26.0+dfsg.1-1.1ubuntu0.2+esm2