p PatchFirst

CVE-2018-8789

CVE-2018-8789

This page contains facts from public vulnerability sources. Check the original advisory before updating.

FreeRDP prior to version 2.0.0-rc4 contains several Out-Of-Bounds Reads in the NTLM Authentication module that results in a Denial of Service (segfault).

CVSS 7.5 · High · EPSS 5.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • freerdp

    Versions
    • All versions prior to 2.0.0-rc4: Affected

    No fix published

  • freerdp2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.0.0~git20181120.1.e21b72c95+dfsg1-1

    Update to 2.0.0~git20181120.1.e21b72c95+dfsg1-1

  • freerdp Ubuntu:16.04:LTS

    Versions
    • 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1
    • 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.2
    Affected ranges
    • ECOSYSTEM: < 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.3

    Update to 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.3

  • freerdp Ubuntu:18.04:LTS

    Versions
    • 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1
    Affected ranges
    • ECOSYSTEM: < 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.1

    Update to 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.1

  • freerdp2 Ubuntu:18.04:LTS

    Versions
    • 2.0.0~git20170725.1.1648deb+dfsg1-1
    • 2.0.0~git20170725.1.1648deb+dfsg1-5
    • 2.0.0~git20170725.1.1648deb+dfsg1-5ubuntu1
    • 2.0.0~git20170725.1.1648deb+dfsg1-5ubuntu2
    • 2.0.0~git20170725.1.1648deb+dfsg1-6
    • 2.0.0~git20170725.1.1648deb+dfsg1-6build1
    • 2.0.0~git20170725.1.1648deb+dfsg1-7
    Affected ranges
    • ECOSYSTEM: < 2.0.0~git20170725.1.1648deb+dfsg1-7ubuntu0.1

    Update to 2.0.0~git20170725.1.1648deb+dfsg1-7ubuntu0.1

Original sources

Check your server →