CVE-2019-0229
CVE-2019-0229
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A number of HTTP endpoints in the Airflow webserver (both RBAC and classic) did not have adequate protection and were vulnerable to cross-site request forgery attacks.
CVSS 8.8 · High · EPSS 1.6% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache airflow
- Versions
- Apache Airflow <= 1.10.2: Affected
No fix published
apache-airflow PyPI
- Versions
- 1.10.0
- 1.10.1
- 1.10.1b1
- 1.10.1rc2
- 1.10.2
- 1.10.2b2
- 1.10.2rc1
- 1.10.2rc2
- 1.10.2rc3
- 1.10.3b1
- 1.10.3b2
- 1.10.3rc1
- 1.10.3rc2
- 1.8.1
- 1.8.2
- 1.8.2rc1
- 1.9.0
- Affected ranges
- ECOSYSTEM: < 1.10.3
Update to 1.10.3
apache-airflow PyPI
- Versions
- 1.10.0
- 1.10.1
- 1.10.1b1
- 1.10.1rc2
- 1.10.2
- 1.10.2b2
- 1.10.2rc1
- 1.10.2rc2
- 1.10.2rc3
- 1.8.1
- 1.8.2
- 1.8.2rc1
- 1.9.0
- Affected ranges
- ECOSYSTEM: < 1.10.3b1
Update to 1.10.3b1