p PatchFirst

CVE-2019-1002100

CVE-2019-1002100

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In all Kubernetes versions prior to v1.11.8, v1.12.6, and v1.13.4, users that are authorized to make patch requests to the Kubernetes API Server can send a specially crafted patch of type "json-patch" (e.g. `kubectl patch --type json` or `"Content-Type: application/json-patch+json"`) that consumes excessive resources while processing, causing a Denial of Service on the API Server.

CVSS 6.5 · Medium · EPSS 16.9% · Fix available

Published
Updated

Stack: system · containers

Affected products and versions

  • kubernetes

    Versions
    • v1.0.x: Affected
    • v1.1.x: Affected
    • v1.2.x: Affected
    • v1.3.x: Affected
    • v1.4.x: Affected
    • v1.5.x: Affected
    • v1.6.x: Affected
    • v1.7.x: Affected
    • v1.8.x: Affected
    • v1.9.x: Affected
    • v1.10.x: Affected
    • ≥ unspecified, < v1.11.8: Affected (custom)
    • ≥ unspecified, < v1.12.6: Affected (custom)
    • ≥ unspecified, < v1.13.4: Affected (custom)

    Update to v1.11.8

  • kubernetes Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.17.4-1

    Update to 1.17.4-1

  • kubernetes Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.17.4-1

    Update to 1.17.4-1

  • kubernetes Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.17.4-1

    Update to 1.17.4-1

Original sources

Check your server →