p PatchFirst

CVE-2019-10092

CVE-2019-10092

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

In Apache HTTP Server 2.4.0-2.4.39, a limited cross-site scripting issue was reported affecting the mod_proxy error page. An attacker could cause the link on the error page to be malformed and instead point to a page of their choice. This would only be exploitable where a server was set up with proxying enabled but was misconfigured in such a way that the Proxy Error page was displayed.

CVSS 6.1 · Medium · EPSS 81.5% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • apache http server

    Versions
    • 2.4.0 to 2.4.39: Affected

    No fix published

  • apache2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.4.41-1

    Update to 2.4.41-1

  • apache2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.4.41-1

    Update to 2.4.41-1

  • apache2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.4.41-1

    Update to 2.4.41-1

  • apache2 Ubuntu:Pro:14.04:LTS

    Versions
    • 2.4.6-2ubuntu2
    • 2.4.6-2ubuntu3
    • 2.4.6-2ubuntu4
    • 2.4.7-1ubuntu1
    • 2.4.7-1ubuntu2
    • 2.4.7-1ubuntu3
    • 2.4.7-1ubuntu4
    • 2.4.7-1ubuntu4.1
    • 2.4.7-1ubuntu4.4
    • 2.4.7-1ubuntu4.5
    • 2.4.7-1ubuntu4.6
    • 2.4.7-1ubuntu4.7
    • 2.4.7-1ubuntu4.8
    • 2.4.7-1ubuntu4.9
    • 2.4.7-1ubuntu4.10
    • 2.4.7-1ubuntu4.11
    • 2.4.7-1ubuntu4.13
    • 2.4.7-1ubuntu4.15
    • 2.4.7-1ubuntu4.16
    • 2.4.7-1ubuntu4.17
    • 2.4.7-1ubuntu4.18
    • 2.4.7-1ubuntu4.19
    • 2.4.7-1ubuntu4.20
    • 2.4.7-1ubuntu4.21
    • 2.4.7-1ubuntu4.22
    • 2.4.7-1ubuntu4.22+esm1
    • 2.4.7-1ubuntu4.22+esm2
    • 2.4.7-1ubuntu4.22+esm3
    • 2.4.7-1ubuntu4.22+esm4
    • 2.4.7-1ubuntu4.22+esm5
    • 2.4.7-1ubuntu4.22+esm6
    • 2.4.7-1ubuntu4.22+esm8
    • 2.4.7-1ubuntu4.22+esm9
    • 2.4.7-1ubuntu4.22+esm10
    • 2.4.7-1ubuntu4.22+esm12
    • 2.4.7-1ubuntu4.22+esm13
    • 2.4.7-1ubuntu4.22+esm14
    • 2.4.7-1ubuntu4.22+esm15
    • 2.4.7-1ubuntu4.22+esm16
    • 2.4.7-1ubuntu4.22+esm17
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • apache2 Ubuntu:16.04:LTS

    Versions
    • 2.4.12-2ubuntu2
    • 2.4.17-1ubuntu1
    • 2.4.17-2ubuntu1
    • 2.4.17-3ubuntu1
    • 2.4.18-1ubuntu1
    • 2.4.18-2ubuntu1
    • 2.4.18-2ubuntu2
    • 2.4.18-2ubuntu3
    • 2.4.18-2ubuntu3.1
    • 2.4.18-2ubuntu3.2
    • 2.4.18-2ubuntu3.3
    • 2.4.18-2ubuntu3.4
    • 2.4.18-2ubuntu3.5
    • 2.4.18-2ubuntu3.7
    • 2.4.18-2ubuntu3.8
    • 2.4.18-2ubuntu3.9
    • 2.4.18-2ubuntu3.10
    Affected ranges
    • ECOSYSTEM: < 2.4.18-2ubuntu3.12

    Update to 2.4.18-2ubuntu3.12

  • apache2 Ubuntu:18.04:LTS

    Versions
    • 2.4.27-2ubuntu3
    • 2.4.29-1ubuntu1
    • 2.4.29-1ubuntu2
    • 2.4.29-1ubuntu3
    • 2.4.29-1ubuntu4
    • 2.4.29-1ubuntu4.1
    • 2.4.29-1ubuntu4.2
    • 2.4.29-1ubuntu4.3
    • 2.4.29-1ubuntu4.4
    • 2.4.29-1ubuntu4.5
    • 2.4.29-1ubuntu4.6
    • 2.4.29-1ubuntu4.7
    • 2.4.29-1ubuntu4.8
    Affected ranges
    • ECOSYSTEM: < 2.4.29-1ubuntu4.10

    Update to 2.4.29-1ubuntu4.10

Original sources

Check your server →