p PatchFirst

CVE-2019-1010142

CVE-2019-1010142

This page contains facts from public vulnerability sources. Check the original advisory before updating.

scapy 2.4.0 is affected by: Denial of Service. The impact is: infinite loop, resource consumption and program unresponsive. The component is: _RADIUSAttrPacketListField.getfield(self..). The attack vector is: over the network or in a pcap. both work.

CVSS 7.5 · High · EPSS 2.8% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • scapy

    Versions
    • 2.4.0: Affected

    No fix published

  • scapy Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.4.2-1

    Update to 2.4.2-1

  • scapy Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.4.2-1

    Update to 2.4.2-1

  • scapy Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.4.2-1

    Update to 2.4.2-1

  • scapy PyPI

    Versions
    • 2.4.0
    • 2.4.0rc3
    • 2.4.0rc4
    • 2.4.0rc5
    • 2.4rc2
    Affected ranges
    • ECOSYSTEM: ≥ 2.4-rc1, < 2.4.1

    Update to 2.4.1

  • scapy PyPI

    Versions
    • 2.2.0-dev
    • 2.3.1
    • 2.3.2
    • 2.3.3
    • 2.4rc2
    • 2.4.0rc3
    • 2.4.0rc4
    • 2.4.0rc5
    • 2.4.0
    Affected ranges
    • ECOSYSTEM: < 2.4.1

    Update to 2.4.1

Original sources

Check your server →