CVE-2019-10134
CVE-2019-10134
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in Moodle before 3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18. The size of users' private file uploads via email were not correctly checked, so their quota allowance could be exceeded.
CVSS 4.2 · Medium · EPSS 1.1% · Fix available
- Published
- Updated
Affected products and versions
moodle
- Versions
- 3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18: Affected
No fix published
moodle/moodle Packagist
- Versions
- v3.6.0
- v3.6.0-beta
- v3.6.0-rc1
- v3.6.0-rc2
- v3.6.0-rc3
- v3.6.1
- v3.6.2
- v3.6.3
- Affected ranges
- ECOSYSTEM: ≥ 3.6, < 3.6.4
Update to 3.6.4
moodle/moodle Packagist
- Versions
- v3.5.0
- v3.5.0-beta
- v3.5.0-rc1
- v3.5.1
- v3.5.2
- v3.5.3
- v3.5.4
- v3.5.5
- Affected ranges
- ECOSYSTEM: ≥ 3.5, < 3.5.6
Update to 3.5.6
moodle/moodle Packagist
- Versions
- v3.4.0
- v3.4.0-beta
- v3.4.0-rc1
- v3.4.0-rc2
- v3.4.0-rc3
- v3.4.1
- v3.4.2
- v3.4.3
- v3.4.4
- v3.4.5
- v3.4.6
- v3.4.7
- v3.4.8
- Affected ranges
- ECOSYSTEM: ≥ 3.4, < 3.4.9
Update to 3.4.9
moodle/moodle Packagist
- Versions
- v3.1.0
- v3.1.0-beta
- v3.1.0-rc1
- v3.1.0-rc2
- v3.1.1
- v3.1.10
- v3.1.11
- v3.1.12
- v3.1.13
- v3.1.14
- v3.1.15
- v3.1.16
- v3.1.17
- v3.1.2
- v3.1.3
- v3.1.4
- v3.1.5
- v3.1.6
- v3.1.7
- v3.1.8
- v3.1.9
- Affected ranges
- ECOSYSTEM: ≥ 3.1, < 3.1.18
Update to 3.1.18
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published