CVE-2019-10156
CVE-2019-10156
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of information disclosure through unexpected variable substitution. By taking advantage of unintended variable substitution the content of any variable may be disclosed.
CVSS 4.6 · Medium · EPSS 1.8% · Fix available
- Published
- Updated
Affected products and versions
ansible
- Versions
- fixed in 2.6.18: Affected
- fixed in 2.7.12: Affected
- fixed in 2.8.2: Affected
No fix published
ansible Debian:12
- Affected ranges
- ECOSYSTEM: < 2.8.3+dfsg-1
Update to 2.8.3+dfsg-1
ansible Debian:13
- Affected ranges
- ECOSYSTEM: < 2.8.3+dfsg-1
Update to 2.8.3+dfsg-1
ansible Debian:14
- Affected ranges
- ECOSYSTEM: < 2.8.3+dfsg-1
Update to 2.8.3+dfsg-1
ansible PyPI
- Versions
- 1.0
- 1.1
- 1.2
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.4
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- 1.5.5
- 1.6
- 1.6.1
- 1.6.10
- 1.6.2
- 1.6.3
- 1.6.4
- 1.6.5
- 1.6.6
- 1.6.7
- 1.6.8
- 1.6.9
- 1.7
- 1.7.1
- 1.7.2
- 1.8
- 1.8.1
- 1.8.2
- 1.8.3
- 1.8.4
- 1.9.0
- 1.9.0.1
- 1.9.1
- 1.9.2
- 1.9.3
- 1.9.4
- 1.9.5
- 1.9.6
- 2.0.0
- 2.0.0.0
- 2.0.0.1
- 2.0.0.2
- 2.0.1.0
- 2.0.2.0
- 2.1.0.0
- 2.1.1.0
- 2.1.2.0
- 2.1.3.0
- 2.1.4.0
- 2.1.5.0
- 2.1.6.0
- 2.2.0.0
- 2.2.1.0
- 2.2.2.0
- 2.2.3.0
- 2.3.0.0
- 2.3.1.0
- 2.3.2.0
- 2.3.3.0
- 2.4.0.0
- 2.4.1.0
- 2.4.2.0
- 2.4.3.0
- 2.4.4.0
- 2.4.5.0
- 2.4.6.0
- 2.5.0
- 2.5.0a1
- 2.5.0b1
- 2.5.0b2
- 2.5.0rc1
- 2.5.0rc2
- 2.5.0rc3
- 2.5.1
- 2.5.10
- 2.5.11
- 2.5.12
- 2.5.13
- 2.5.14
- 2.5.15
- 2.5.2
- 2.5.3
- 2.5.4
- 2.5.5
- 2.5.6
- 2.5.7
- 2.5.8
- 2.5.9
- 2.6.0
- 2.6.0a1
- 2.6.0a2
- 2.6.0rc1
- 2.6.0rc2
- 2.6.0rc3
- 2.6.0rc4
- 2.6.0rc5
- 2.6.1
- 2.6.10
- 2.6.11
- 2.6.12
- 2.6.13
- 2.6.14
- 2.6.15
- 2.6.16
- 2.6.17
- 2.6.2
- 2.6.3
- 2.6.4
- 2.6.5
- 2.6.6
- 2.6.7
- 2.6.8
- 2.6.9
- Affected ranges
- ECOSYSTEM: < 2.6.18
Update to 2.6.18
ansible PyPI
- Versions
- 2.7.0
- 2.7.0a1
- 2.7.0b1
- 2.7.0rc1
- 2.7.0rc2
- 2.7.0rc3
- 2.7.0rc4
- 2.7.1
- 2.7.10
- 2.7.11
- 2.7.2
- 2.7.3
- 2.7.4
- 2.7.5
- 2.7.6
- 2.7.7
- 2.7.8
- 2.7.9
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0a1, < 2.7.12
Update to 2.7.12
ansible PyPI
- Versions
- 2.8.0
- 2.8.0a1
- 2.8.0b1
- 2.8.0rc1
- 2.8.0rc2
- 2.8.0rc3
- 2.8.1
- Affected ranges
- ECOSYSTEM: ≥ 2.8.0a1, < 2.8.2
Update to 2.8.2
ansible PyPI
- Versions
- 1.0
- 1.1
- 1.2
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.4
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- 1.5.5
- 1.6
- 1.6.1
- 1.6.2
- 1.6.3
- 1.6.4
- 1.6.5
- 1.6.6
- 1.6.7
- 1.6.8
- 1.6.9
- 1.6.10
- 1.7
- 1.7.1
- 1.7.2
- 1.8
- 1.8.1
- 1.8.2
- 1.8.3
- 1.8.4
- 1.9.0
- 1.9.0.1
- 1.9.1
- 1.9.2
- 1.9.3
- 1.9.4
- 1.9.5
- 1.9.6
- 2.0.0.0
- 2.0.0
- 2.0.0.1
- 2.0.0.2
- 2.0.1.0
- 2.0.2.0
- 2.1.0.0
- 2.1.1.0
- 2.1.2.0
- 2.1.3.0
- 2.1.4.0
- 2.1.5.0
- 2.1.6.0
- 2.2.0.0
- 2.2.1.0
- 2.2.2.0
- 2.2.3.0
- 2.3.0.0
- 2.3.1.0
- 2.3.2.0
- 2.3.3.0
- 2.4.0.0
- 2.4.1.0
- 2.4.2.0
- 2.4.3.0
- 2.4.4.0
- 2.4.5.0
- 2.4.6.0
- 2.5.0a1
- 2.5.0b1
- 2.5.0b2
- 2.5.0rc1
- 2.5.0rc2
- 2.5.0rc3
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.5.4
- 2.5.5
- 2.5.6
- 2.5.7
- 2.5.8
- 2.5.9
- 2.5.10
- 2.5.11
- 2.5.12
- 2.5.13
- 2.5.14
- 2.5.15
- 2.6.0a1
- 2.6.0a2
- 2.6.0rc1
- 2.6.0rc2
- 2.6.0rc3
- 2.6.0rc4
- 2.6.0rc5
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- 2.6.4
- 2.6.5
- 2.6.6
- 2.6.7
- 2.6.8
- 2.6.9
- 2.6.10
- 2.6.11
- 2.6.12
- 2.6.13
- 2.6.14
- 2.6.15
- 2.6.16
- 2.6.17
- 2.7.0
- 2.7.1
- 2.7.2
- 2.7.3
- 2.7.4
- 2.7.5
- 2.7.6
- 2.7.7
- 2.7.8
- 2.7.9
- 2.7.10
- 2.7.11
- 2.8.0
- 2.8.1
- Affected ranges
- ECOSYSTEM: < 2.6.18 ∪ ≥ 2.7.0, < 2.7.12 ∪ ≥ 2.8.0, < 2.8.2
Update to 2.6.18; Update to 2.7.12; Update to 2.8.2
ansible Ubuntu:18.04:LTS
- Versions
- 2.3.1.0+dfsg-2
- 2.5.0+dfsg-1
- 2.5.1+dfsg-1
- Affected ranges
- ECOSYSTEM: < 2.5.1+dfsg-1ubuntu0.1
Update to 2.5.1+dfsg-1ubuntu0.1
Original sources
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10156
- https://github.com/ansible/ansible/pull/57188
- https://lists.debian.org/debian-lts-announce/2019/09/msg00016.html
- https://access.redhat.com/errata/RHSA-2019:3744
- https://access.redhat.com/errata/RHSA-2019:3789
- https://lists.debian.org/debian-lts-announce/2021/01/msg00023.html
- https://www.debian.org/security/2021/dsa-4950
- https://nvd.nist.gov/vuln/detail/CVE-2019-10156