CVE-2019-10166
CVE-2019-10166
This page contains facts from public vulnerability sources. Check the original advisory before updating.
It was discovered that libvirtd, versions 4.x.x before 4.10.1 and 5.x.x before 5.4.1, would permit readonly clients to use the virDomainManagedSaveDefineXML() API, which would permit them to modify managed save state files. If a managed save had already been created by a privileged user, a local attacker could modify this file such that libvirtd would execute an arbitrary program when the domain was resumed.
CVSS 7.8 · High · EPSS 0.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
libvirt
- Versions
- 4.x.x before 4.10.1: Affected
- 5.x.x before 5.4.1: Affected
No fix published
libvirt Debian:12
- Affected ranges
- ECOSYSTEM: < 5.0.0-4
Update to 5.0.0-4
libvirt Debian:13
- Affected ranges
- ECOSYSTEM: < 5.0.0-4
Update to 5.0.0-4
libvirt Debian:14
- Affected ranges
- ECOSYSTEM: < 5.0.0-4
Update to 5.0.0-4
libvirt Ubuntu:18.04:LTS
- Versions
- 3.6.0-1ubuntu5
- 3.6.0-1ubuntu6
- 4.0.0-1ubuntu1
- 4.0.0-1ubuntu2
- 4.0.0-1ubuntu3
- 4.0.0-1ubuntu4
- 4.0.0-1ubuntu5
- 4.0.0-1ubuntu6
- 4.0.0-1ubuntu7
- 4.0.0-1ubuntu8
- 4.0.0-1ubuntu8.1
- 4.0.0-1ubuntu8.2
- 4.0.0-1ubuntu8.3
- 4.0.0-1ubuntu8.4
- 4.0.0-1ubuntu8.5
- 4.0.0-1ubuntu8.6
- 4.0.0-1ubuntu8.7
- 4.0.0-1ubuntu8.8
- 4.0.0-1ubuntu8.9
- 4.0.0-1ubuntu8.10
- 4.0.0-1ubuntu8.11
- Affected ranges
- ECOSYSTEM: < 4.0.0-1ubuntu8.12
Update to 4.0.0-1ubuntu8.12