p PatchFirst

CVE-2019-10168

CVE-2019-10168

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The virConnectBaselineHypervisorCPU() and virConnectCompareHypervisorCPU() libvirt APIs, 4.x.x before 4.10.1 and 5.x.x before 5.4.1, accept an "emulator" argument to specify the program providing emulation for a domain. Since v1.2.19, libvirt will execute that program to probe the domain's capabilities. Read-only clients could specify an arbitrary path for this argument, causing libvirtd to execute a crafted executable with its own privileges.

CVSS 8.8 · High · EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • libvirt

    Versions
    • 4.x.x before 4.10.1: Affected
    • 5.x.x before 5.4.1: Affected

    No fix published

  • libvirt Debian:12

    Affected ranges
    • ECOSYSTEM: < 5.0.0-4

    Update to 5.0.0-4

  • libvirt Debian:13

    Affected ranges
    • ECOSYSTEM: < 5.0.0-4

    Update to 5.0.0-4

  • libvirt Debian:14

    Affected ranges
    • ECOSYSTEM: < 5.0.0-4

    Update to 5.0.0-4

Original sources

Check your server →