p PatchFirst

CVE-2019-10187

CVE-2019-10187

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Users with permission to delete entries from a glossary were able to delete entries from other glossaries they did not have direct access to.

CVSS 4.0 · Medium · EPSS 0.9% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • moodle

    Versions
    • 3.7.1: Affected
    • 3.6.5: Affected
    • 3.5.7: Affected

    No fix published

  • moodle/moodle Packagist

    Versions
    • v3.7.0
    • v3.7.0-beta
    • v3.7.0-rc1
    • v3.7.0-rc2
    Affected ranges
    • ECOSYSTEM: ≥ 3.7, < 3.7.1

    Update to 3.7.1

  • moodle/moodle Packagist

    Versions
    • v3.6.0
    • v3.6.0-beta
    • v3.6.0-rc1
    • v3.6.0-rc2
    • v3.6.0-rc3
    • v3.6.1
    • v3.6.2
    • v3.6.3
    • v3.6.4
    Affected ranges
    • ECOSYSTEM: ≥ 3.6, < 3.6.5

    Update to 3.6.5

  • moodle/moodle Packagist

    Versions
    • v3.5.0
    • v3.5.0-beta
    • v3.5.0-rc1
    • v3.5.1
    • v3.5.2
    • v3.5.3
    • v3.5.4
    • v3.5.5
    • v3.5.6
    Affected ranges
    • ECOSYSTEM: ≥ 3.5, < 3.5.7

    Update to 3.5.7

  • moodle Ubuntu:Pro:16.04:LTS

    Versions
    • 2.7.9+dfsg-1
    • 2.7.10+dfsg-1
    • 2.7.11+dfsg-1
    • 2.7.11+dfsg-2
    • 2.7.12+dfsg-1
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • moodle Ubuntu:Pro:18.04:LTS

    Versions
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →