CVE-2019-10195
CVE-2019-10195
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in IPA, all 4.6.x versions before 4.6.7, all 4.7.x versions before 4.7.4 and all 4.8.x versions before 4.8.3, in the way that FreeIPA's batch processing API logged operations. This included passing user passwords in clear text on FreeIPA masters. Batch processing of commands with passwords as arguments or options is not performed by default in FreeIPA but is possible by third-party components. An attacker having access to system logs on FreeIPA masters could use this flaw to produce log file content with passwords exposed.
CVSS 5.7 · Medium · EPSS 1.8% · Fix available
- Published
- Updated
Affected products and versions
ipa
- Versions
- all IPA 4.6.x versions before 4.6.7: Affected
- all IPA 4.7.x versions before 4.7.4: Affected
- all IPa 4.8.x versions before 4.8.3: Affected
No fix published
freeipa Debian:12
- Affected ranges
- ECOSYSTEM: < 4.8.3-1
Update to 4.8.3-1
freeipa Debian:13
- Affected ranges
- ECOSYSTEM: < 4.8.3-1
Update to 4.8.3-1
freeipa PyPI
- Versions
- 4.6.1
- 4.6.2
- 4.6.3
- 4.6.4
- 4.6.5
- Affected ranges
- ECOSYSTEM: ≥ 4.6.0, < 4.6.7
Update to 4.6.7
freeipa PyPI
- Versions
- 4.7.0
- 4.7.1
- 4.7.2
- Affected ranges
- ECOSYSTEM: ≥ 4.7.0, < 4.7.4
Update to 4.7.4
freeipa PyPI
- Versions
- 4.8.0
- 4.8.1
- 4.8.2
- Affected ranges
- ECOSYSTEM: ≥ 4.8.0, < 4.8.3
Update to 4.8.3
ipa PyPI
- Versions
- 4.6.2
- 4.6.3
- 4.6.4
- 4.6.5
- Affected ranges
- ECOSYSTEM: ≥ 4.6.0, < 4.6.7
Update to 4.6.7
ipa PyPI
- Versions
- 4.7.0
- 4.7.1
- 4.7.2
- Affected ranges
- ECOSYSTEM: ≥ 4.7.0, < 4.7.4
Update to 4.7.4
ipa PyPI
- Versions
- 4.8.0
- 4.8.1
- 4.8.2
- Affected ranges
- ECOSYSTEM: ≥ 4.8.0, < 4.8.3
Update to 4.8.3
ipa PyPI
- Versions
- 4.6.2
- 4.6.3
- 4.6.4
- 4.6.5
- 4.7.0
- 4.7.1
- 4.7.2
- 4.8.0
- 4.8.1
- 4.8.2
- Affected ranges
- ECOSYSTEM: ≥ 4.6.0, < 4.6.7 ∪ ≥ 4.7.0, < 4.7.4 ∪ ≥ 4.8.0, < 4.8.3
Update to 4.6.7; Update to 4.7.4; Update to 4.8.3
freeipa PyPI
- Versions
- 4.6.1
- 4.6.2
- 4.6.3
- 4.6.4
- 4.6.5
- 4.7.0
- 4.7.1
- 4.7.2
- 4.8.0
- 4.8.1
- 4.8.2
- Affected ranges
- ECOSYSTEM: ≥ 4.6.1, < 4.6.7 ∪ ≥ 4.7.0, < 4.7.4 ∪ ≥ 4.8.0, < 4.8.3
Update to 4.6.7; Update to 4.7.4; Update to 4.8.3
freeipa Ubuntu:Pro:14.04:LTS
- Versions
- 3.2.1-0ubuntu1
- 3.3.4-0ubuntu1
- 3.3.4-0ubuntu2
- 3.3.4-0ubuntu3
- 3.3.4-0ubuntu3.1
- 3.3.4-0ubuntu3.1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
freeipa Ubuntu:Pro:16.04:LTS
- Versions
- 4.1.4-1
- 4.3.1-0ubuntu1
- 4.3.1-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
freeipa Ubuntu:18.04:LTS
- Versions
- 4.4.4-3ubuntu1
- 4.4.4-4
- 4.7.0~pre1+git20180411-2ubuntu1
- 4.7.0~pre1+git20180411-2ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
freeipa Ubuntu:20.04:LTS
- Versions
- 4.8.1-2ubuntu1
- 4.8.3-1
- 4.8.6-1ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
freeipa Ubuntu:22.04:LTS
- Versions
- 4.8.6-1ubuntu6
- 4.8.6-1ubuntu8
- 4.8.6-1ubuntu9
- 4.9.8-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://www.freeipa.org/page/Releases/4.7.4
- https://www.freeipa.org/page/Releases/4.8.3
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10195
- https://www.freeipa.org/page/Releases/4.6.7
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WLFL5XDCJ3WT6JCLCQVKHZBLHGW7PW4T/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/67SEUWJAJ5RMH5K4Q6TS2I7HIMXUGNKF/
- https://access.redhat.com/errata/RHSA-2020:0378
- https://access.redhat.com/errata/RHBA-2019:4268
- https://nvd.nist.gov/vuln/detail/CVE-2019-10195