p PatchFirst

CVE-2019-10197

CVE-2019-10197

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A flaw was found in samba versions 4.9.x up to 4.9.13, samba 4.10.x up to 4.10.8 and samba 4.11.x up to 4.11.0rc3, when certain parameters were set in the samba configuration file. An unauthenticated attacker could use this flaw to escape the shared directory and access the contents of directories outside the share.

CVSS 6.5 · Medium · EPSS 3.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • samba

    Versions
    • samba 4.9.x up to 4.9.13: Affected
    • samba 4.10.x up to 4.10.8: Affected
    • samba 4.11.x up to 4.11.0rc3: Affected

    No fix published

  • samba Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:4.9.13+dfsg-1

    Update to 2:4.9.13+dfsg-1

  • samba Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:4.9.13+dfsg-1

    Update to 2:4.9.13+dfsg-1

  • samba Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:4.9.13+dfsg-1

    Update to 2:4.9.13+dfsg-1

Original sources

Check your server →