CVE-2019-10206
CVE-2019-10206
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.
CVSS 6.4 · Medium · EPSS 1.5% · Fix available
- Published
- Updated
Affected products and versions
ansible
- Versions
- all 2.8.x before 2.8.4: Affected
- all 2.7.x before 2.7.13: Affected
- all 2.6.x before 2.6.19: Affected
No fix published
ansible Debian:12
- Affected ranges
- ECOSYSTEM: < 2.8.6+dfsg-1
Update to 2.8.6+dfsg-1
ansible Debian:13
- Affected ranges
- ECOSYSTEM: < 2.8.6+dfsg-1
Update to 2.8.6+dfsg-1
ansible Debian:14
- Affected ranges
- ECOSYSTEM: < 2.8.6+dfsg-1
Update to 2.8.6+dfsg-1
ansible PyPI
- Versions
- 2.8.0
- 2.8.1
- 2.8.2
- 2.8.3
- Affected ranges
- ECOSYSTEM: ≥ 2.8.0, < 2.8.4
Update to 2.8.4
ansible PyPI
- Versions
- 2.7.0
- 2.7.1
- 2.7.10
- 2.7.11
- 2.7.12
- 2.7.2
- 2.7.3
- 2.7.4
- 2.7.5
- 2.7.6
- 2.7.7
- 2.7.8
- 2.7.9
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.13
Update to 2.7.13
ansible PyPI
- Versions
- 2.6.0
- 2.6.1
- 2.6.10
- 2.6.11
- 2.6.12
- 2.6.13
- 2.6.14
- 2.6.15
- 2.6.16
- 2.6.17
- 2.6.18
- 2.6.2
- 2.6.3
- 2.6.4
- 2.6.5
- 2.6.6
- 2.6.7
- 2.6.8
- 2.6.9
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.6.19
Update to 2.6.19
ansible PyPI
- Versions
- 2.6.0
- 2.6.1
- 2.6.10
- 2.6.11
- 2.6.12
- 2.6.13
- 2.6.14
- 2.6.15
- 2.6.16
- 2.6.17
- 2.6.18
- 2.6.2
- 2.6.3
- 2.6.4
- 2.6.5
- 2.6.6
- 2.6.7
- 2.6.8
- 2.6.9
- 2.7.0
- 2.7.1
- 2.7.10
- 2.7.11
- 2.7.12
- 2.7.2
- 2.7.3
- 2.7.4
- 2.7.5
- 2.7.6
- 2.7.7
- 2.7.8
- 2.7.9
- 2.8.0
- 2.8.1
- 2.8.2
- 2.8.3
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.6.19 ∪ ≥ 2.7.0, < 2.7.13 ∪ ≥ 2.8.0, < 2.8.4
Update to 2.6.19; Update to 2.7.13; Update to 2.8.4
ansible Ubuntu:Pro:16.04:LTS
- Versions
- 1.9.2+dfsg-2
- 1.9.4-1
- 2.0.0.2-2
- 2.0.0.2-2ubuntu1
- 2.0.0.2-2ubuntu1.1
- 2.0.0.2-2ubuntu1.2
- 2.0.0.2-2ubuntu1.3
- 2.0.0.2-2ubuntu1.3+esm1
- 2.0.0.2-2ubuntu1.3+esm2
- 2.0.0.2-2ubuntu1.3+esm3
- 2.0.0.2-2ubuntu1.3+esm4
- Affected ranges
- ECOSYSTEM: < 2.0.0.2-2ubuntu1.3+esm5
Update to 2.0.0.2-2ubuntu1.3+esm5
ansible Ubuntu:Pro:18.04:LTS
- Versions
- 2.3.1.0+dfsg-2
- 2.5.0+dfsg-1
- 2.5.1+dfsg-1
- 2.5.1+dfsg-1ubuntu0.1
- 2.5.1+dfsg-1ubuntu0.1+esm1
- 2.5.1+dfsg-1ubuntu0.1+esm2
- 2.5.1+dfsg-1ubuntu0.1+esm3
- 2.5.1+dfsg-1ubuntu0.1+esm4
- Affected ranges
- ECOSYSTEM: < 2.5.1+dfsg-1ubuntu0.1+esm5
Update to 2.5.1+dfsg-1ubuntu0.1+esm5
Original sources
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html
- https://www.debian.org/security/2021/dsa-4950
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10206
- https://lists.debian.org/debian-lts-announce/2023/12/msg00018.html
- https://nvd.nist.gov/vuln/detail/CVE-2019-10206