CVE-2019-10784
CVE-2019-10784
This page contains facts from public vulnerability sources. Check the original advisory before updating.
phppgadmin through 7.12.1 allows sensitive actions to be performed without validating that the request originated from the application. One such area, "database.php" does not verify the source of an HTTP request. This can be leveraged by a remote attacker to trick a logged-in administrator to visit a malicious page with a CSRF exploit and execute arbitrary system commands on the server.
CVSS 9.6 · Critical · EPSS 3.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
phppgadmin
- Versions
- All versions: Affected
No fix published
phppgadmin Debian:13
- Affected ranges
- ECOSYSTEM: < 7.14.7+dfsg-1
Update to 7.14.7+dfsg-1
phppgadmin Debian:14
- Affected ranges
- ECOSYSTEM: < 7.14.7+dfsg-1
Update to 7.14.7+dfsg-1
phppgadmin Ubuntu:16.04:LTS
- Versions
- 5.1+ds-1
- 5.1+ds-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
phppgadmin Ubuntu:18.04:LTS
- Versions
- 5.1+ds-2
- 5.1+ds-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
phppgadmin Ubuntu:20.04:LTS
- Versions
- 5.1+ds-4
- 7.12.0+ds-2
- 7.12.0+ds-3
- 7.12.1+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
phppgadmin Ubuntu:22.04:LTS
- Versions
- 7.13.0+dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
phppgadmin Ubuntu:24.04:LTS
- Versions
- 7.13.0+dfsg-2
- 7.13.0+dfsg-3
- 7.14.7+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
phppgadmin Ubuntu:25.10
- Versions
- 7.14.7+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
phppgadmin Ubuntu:26.10
- Versions
- 7.14.7+dfsg-1build1
- 7.14.8+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
phppgadmin Ubuntu:26.04:LTS
- Versions
- 7.14.7+dfsg-1
- 7.14.7+dfsg-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published