p PatchFirst

CVE-2019-11281

CVE-2019-11281 · RabbitMQ XSS attack

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Pivotal RabbitMQ, versions prior to v3.7.18, and RabbitMQ for PCF, versions 1.15.x prior to 1.15.13, versions 1.16.x prior to 1.16.6, and versions 1.17.x prior to 1.17.3, contain two components, the virtual host limits page, and the federation management UI, which do not properly sanitize user input. A remote authenticated malicious user with administrative access could craft a cross site scripting attack that would gain access to virtual hosts and policy management information.

CVSS 2.4 · Low · EPSS 1.2% · Fix available

Published
Updated

Stack: system · database

Affected products and versions

  • rabbitmq

    Versions
    • prior to v3.7.18: Affected

    No fix published

  • rabbitmq for pcf

    Versions
    • 1.15.x prior to 1.15.13: Affected
    • 11.16.x prior to 1.16.6: Affected
    • 1.17.x prior to 1.17.3: Affected

    No fix published

  • rabbitmq-server Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.7.18-1

    Update to 3.7.18-1

  • rabbitmq-server Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.7.18-1

    Update to 3.7.18-1

  • rabbitmq-server Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.7.18-1

    Update to 3.7.18-1

Original sources

Check your server →