CVE-2019-11325
CVE-2019-11325
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue was discovered in Symfony before 4.2.12 and 4.3.x before 4.3.8. The VarExport component incorrectly escapes strings, allowing some specially crafted ones to escalate to execution of arbitrary PHP code. This is related to symfony/var-exporter.
CVSS 9.8 · Critical · EPSS 3.4% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
symfony Debian:12
- Affected ranges
- ECOSYSTEM: < 4.3.8+dfsg-1
Update to 4.3.8+dfsg-1
symfony Debian:13
- Affected ranges
- ECOSYSTEM: < 4.3.8+dfsg-1
Update to 4.3.8+dfsg-1
symfony Debian:14
- Affected ranges
- ECOSYSTEM: < 4.3.8+dfsg-1
Update to 4.3.8+dfsg-1
symfony/symfony Packagist
- Versions
- v4.2.0
- v4.2.1
- v4.2.10
- v4.2.11
- v4.2.2
- v4.2.3
- v4.2.4
- v4.2.5
- v4.2.6
- v4.2.7
- v4.2.8
- v4.2.9
- Affected ranges
- ECOSYSTEM: ≥ 4.2.0, < 4.2.12
Update to 4.2.12
symfony/symfony Packagist
- Versions
- v4.3.0
- v4.3.1
- v4.3.2
- v4.3.3
- v4.3.4
- v4.3.5
- v4.3.6
- v4.3.7
- Affected ranges
- ECOSYSTEM: ≥ 4.3.0, < 4.3.8
Update to 4.3.8
symfony/var-exporter Packagist
- Versions
- v4.2.0
- v4.2.1
- v4.2.10
- v4.2.11
- v4.2.2
- v4.2.3
- v4.2.4
- v4.2.5
- v4.2.6
- v4.2.7
- v4.2.8
- v4.2.9
- Affected ranges
- ECOSYSTEM: ≥ 4.2.0, < 4.2.12
Update to 4.2.12
symfony/var-exporter Packagist
- Versions
- v4.3.0
- v4.3.1
- v4.3.2
- v4.3.3
- v4.3.4
- v4.3.5
- v4.3.6
- v4.3.7
- Affected ranges
- ECOSYSTEM: ≥ 4.3.0, < 4.3.8
Update to 4.3.8