CVE-2019-11707
CVE-2019-11707
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A type confusion vulnerability can occur when manipulating JavaScript objects due to issues in Array.pop. This can allow for an exploitable crash. We are aware of targeted attacks in the wild abusing this flaw. This vulnerability affects Firefox ESR < 60.7.1, Firefox < 67.0.3, and Thunderbird < 60.7.2.
CVSS 8.8 · High · EPSS 38.0% · In KEV · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
firefox esr
- Versions
- ≥ unspecified, < 60.7.1: Affected (custom)
Update to 60.7.1
firefox
- Versions
- ≥ unspecified, < 67.0.3: Affected (custom)
Update to 67.0.3
thunderbird
- Versions
- ≥ unspecified, < 60.7.2: Affected (custom)
Update to 60.7.2
firefox-esr Debian:12
- Affected ranges
- ECOSYSTEM: < 60.7.1esr-1
Update to 60.7.1esr-1
firefox-esr Debian:13
- Affected ranges
- ECOSYSTEM: < 60.7.1esr-1
Update to 60.7.1esr-1
firefox-esr Debian:14
- Affected ranges
- ECOSYSTEM: < 60.7.1esr-1
Update to 60.7.1esr-1
thunderbird Debian:12
- Affected ranges
- ECOSYSTEM: < 1:60.7.2-1
Update to 1:60.7.2-1
thunderbird Debian:13
- Affected ranges
- ECOSYSTEM: < 1:60.7.2-1
Update to 1:60.7.2-1
thunderbird Debian:14
- Affected ranges
- ECOSYSTEM: < 1:60.7.2-1
Update to 1:60.7.2-1
firefox Ubuntu:16.04:LTS
- Versions
- 41.0.2+build2-0ubuntu1
- 42.0+build2-0ubuntu1
- 44.0+build3-0ubuntu2
- 44.0.1+build1-0ubuntu1
- 44.0.2+build1-0ubuntu1
- 45.0+build2-0ubuntu1
- 45.0.1+build1-0ubuntu1
- 45.0.2+build1-0ubuntu1
- 46.0+build5-0ubuntu0.16.04.2
- 46.0.1+build1-0ubuntu0.16.04.2
- 47.0+build3-0ubuntu0.16.04.1
- 48.0+build2-0ubuntu0.16.04.1
- 49.0+build4-0ubuntu0.16.04.1
- 49.0.2+build2-0ubuntu0.16.04.2
- 50.0+build2-0ubuntu0.16.04.2
- 50.0.2+build1-0ubuntu0.16.04.1
- 50.1.0+build2-0ubuntu0.16.04.1
- 51.0.1+build2-0ubuntu0.16.04.1
- 51.0.1+build2-0ubuntu0.16.04.2
- 52.0+build2-0ubuntu0.16.04.1
- 52.0.1+build2-0ubuntu0.16.04.1
- 52.0.2+build1-0ubuntu0.16.04.1
- 53.0+build6-0ubuntu0.16.04.1
- 53.0.2+build1-0ubuntu0.16.04.2
- 53.0.3+build1-0ubuntu0.16.04.2
- 54.0+build3-0ubuntu0.16.04.1
- 55.0.1+build2-0ubuntu0.16.04.2
- 55.0.2+build1-0ubuntu0.16.04.1
- 56.0+build6-0ubuntu0.16.04.1
- 56.0+build6-0ubuntu0.16.04.2
- 57.0+build4-0ubuntu0.16.04.5
- 57.0+build4-0ubuntu0.16.04.6
- 57.0.1+build2-0ubuntu0.16.04.1
- 57.0.3+build1-0ubuntu0.16.04.1
- 57.0.4+build1-0ubuntu0.16.04.1
- 58.0+build6-0ubuntu0.16.04.1
- 58.0.1+build1-0ubuntu0.16.04.1
- 58.0.2+build1-0ubuntu0.16.04.1
- 59.0+build5-0ubuntu0.16.04.1
- 59.0.1+build1-0ubuntu0.16.04.1
- 59.0.2+build1-0ubuntu0.16.04.1
- 59.0.2+build1-0ubuntu0.16.04.3
- 60.0+build2-0ubuntu0.16.04.1
- 60.0.1+build2-0ubuntu0.16.04.1
- 60.0.2+build1-0ubuntu0.16.04.1
- 61.0+build3-0ubuntu0.16.04.2
- 61.0.1+build1-0ubuntu0.16.04.1
- 62.0+build2-0ubuntu0.16.04.3
- 62.0+build2-0ubuntu0.16.04.4
- 62.0+build2-0ubuntu0.16.04.5
- 62.0.3+build1-0ubuntu0.16.04.2
- 63.0+build2-0ubuntu0.16.04.2
- 63.0.3+build1-0ubuntu0.16.04.1
- 64.0+build3-0ubuntu0.16.04.1
- 65.0+build2-0ubuntu0.16.04.1
- 65.0.1+build2-0ubuntu0.16.04.1
- 66.0+build3-0ubuntu0.16.04.2
- 66.0.1+build1-0ubuntu0.16.04.1
- 66.0.2+build1-0ubuntu0.16.04.1
- 66.0.3+build1-0ubuntu0.16.04.1
- 66.0.4+build3-0ubuntu0.16.04.1
- 66.0.5+build1-0ubuntu0.16.04.1
- 67.0+build2-0ubuntu0.16.04.1
- 67.0.1+build1-0ubuntu0.16.04.1
- 67.0.2+build2-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 67.0.3+build1-0ubuntu0.16.04.1
Update to 67.0.3+build1-0ubuntu0.16.04.1
firefox Ubuntu:18.04:LTS
- Versions
- 56.0+build6-0ubuntu1
- 57.0.1+build2-0ubuntu1
- 59.0.1+build1-0ubuntu1
- 59.0.2+build1-0ubuntu1
- 60.0+build2-0ubuntu1
- 60.0.1+build2-0ubuntu0.18.04.1
- 60.0.2+build1-0ubuntu0.18.04.1
- 61.0+build3-0ubuntu0.18.04.1
- 61.0.1+build1-0ubuntu0.18.04.1
- 62.0+build2-0ubuntu0.18.04.3
- 62.0+build2-0ubuntu0.18.04.4
- 62.0+build2-0ubuntu0.18.04.5
- 62.0.3+build1-0ubuntu0.18.04.1
- 63.0+build2-0ubuntu0.18.04.2
- 63.0.3+build1-0ubuntu0.18.04.1
- 64.0+build3-0ubuntu0.18.04.1
- 65.0+build2-0ubuntu0.18.04.1
- 65.0.1+build2-0ubuntu0.18.04.1
- 66.0+build3-0ubuntu0.18.04.1
- 66.0.1+build1-0ubuntu0.18.04.1
- 66.0.2+build1-0ubuntu0.18.04.1
- 66.0.3+build1-0ubuntu0.18.04.1
- 66.0.4+build3-0ubuntu0.18.04.1
- 66.0.5+build1-0ubuntu0.18.04.1
- 67.0+build2-0ubuntu0.18.04.1
- 67.0.1+build1-0ubuntu0.18.04.1
- 67.0.2+build2-0ubuntu0.18.04.1
- Affected ranges
- ECOSYSTEM: < 67.0.3+build1-0ubuntu0.18.04.1
Update to 67.0.3+build1-0ubuntu0.18.04.1
mozjs52 Ubuntu:18.04:LTS
- Versions
- 52.3.1-0ubuntu3
- 52.3.1-7fakesync1
- 52.8.1-0ubuntu0.18.04.1
- 52.9.1-0ubuntu0.18.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mozjs52 Ubuntu:20.04:LTS
- Versions
- 52.9.1-1build1
- 52.9.1-1ubuntu3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://www.mozilla.org/security/advisories/mfsa2019-20/
- https://www.mozilla.org/security/advisories/mfsa2019-18/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1544386
- https://security.gentoo.org/glsa/201908-12
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2019-11707
- https://nvd.nist.gov/vuln/detail/CVE-2019-11707