CVE-2019-1353
CVE-2019-1353
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue was found in Git before v2.24.1, v2.23.1, v2.22.2, v2.21.1, v2.20.2, v2.19.3, v2.18.2, v2.17.3, v2.16.6, v2.15.4, and v2.14.6. When running Git in the Windows Subsystem for Linux (also known as "WSL") while accessing a working directory on a regular Windows drive, none of the NTFS protections were active.
CVSS 9.8 · Critical · EPSS 2.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
git
- Versions
- Before 2.24.1, 2.23.1, 2.22.2, 2.21.1, 2.20.2, 2.19.3, 2.18.2, 2.17.3, 2.16.6, 2.15.4, 2.14.6: Affected
No fix published
git Debian:12
- Affected ranges
- ECOSYSTEM: < 1:2.24.0-2
Update to 1:2.24.0-2
git Debian:13
- Affected ranges
- ECOSYSTEM: < 1:2.24.0-2
Update to 1:2.24.0-2
git Debian:14
- Affected ranges
- ECOSYSTEM: < 1:2.24.0-2
Update to 1:2.24.0-2
git Ubuntu:16.04:LTS
- Versions
- 1:2.5.0-1
- 1:2.6.2-1
- 1:2.6.3-1
- 1:2.6.4-1
- 1:2.7.0~rc3-1
- 1:2.7.0-1
- 1:2.7.3-0ubuntu1
- 1:2.7.4-0ubuntu1
- 1:2.7.4-0ubuntu1.1
- 1:2.7.4-0ubuntu1.2
- 1:2.7.4-0ubuntu1.3
- 1:2.7.4-0ubuntu1.4
- 1:2.7.4-0ubuntu1.5
- 1:2.7.4-0ubuntu1.6
- Affected ranges
- ECOSYSTEM: < 1:2.7.4-0ubuntu1.7
Update to 1:2.7.4-0ubuntu1.7
git Ubuntu:18.04:LTS
- Versions
- 1:2.14.1-1ubuntu4
- 1:2.15.1-1ubuntu2
- 1:2.17.0-1ubuntu1
- 1:2.17.1-1ubuntu0.1
- 1:2.17.1-1ubuntu0.3
- 1:2.17.1-1ubuntu0.4
- Affected ranges
- ECOSYSTEM: < 1:2.17.1-1ubuntu0.5
Update to 1:2.17.1-1ubuntu0.5
Original sources
- https://lore.kernel.org/git/xmqqr21cqcn9.fsf%40gitster-ct.c.googlers.com/T/#u
- https://public-inbox.org/git/xmqqr21cqcn9.fsf%40gitster-ct.c.googlers.com/
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00056.html
- https://security.gentoo.org/glsa/202003-30
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00003.html
- https://nvd.nist.gov/vuln/detail/CVE-2019-1353