CVE-2019-13619
CVE-2019-13619
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Wireshark 3.0.0 to 3.0.2, 2.6.0 to 2.6.9, and 2.4.0 to 2.4.15, the ASN.1 BER dissector and related dissectors could crash. This was addressed in epan/asn1.c by properly restricting buffer increments.
CVSS 7.5 · High · EPSS 6.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wireshark Debian:12
- Affected ranges
- ECOSYSTEM: < 2.6.10-1
Update to 2.6.10-1
wireshark Debian:13
- Affected ranges
- ECOSYSTEM: < 2.6.10-1
Update to 2.6.10-1
wireshark Debian:14
- Affected ranges
- ECOSYSTEM: < 2.6.10-1
Update to 2.6.10-1
wireshark Ubuntu:Pro:14.04:LTS
- Versions
- 1.10.2-1
- 1.10.3-1
- 1.10.5-1ubuntu1
- 1.10.5-2
- 1.10.6-1
- 1.12.1+g01b65bf-4+deb8u11ubuntu0.14.04.1
- 2.6.3-1~ubuntu14.04.1
- 2.6.4-2~ubuntu14.04.1
- 2.6.5-1~ubuntu14.04.1
- 2.6.6-1~ubuntu14.04.0
- 2.6.8-1~ubuntu14.04.0~esm1
- Affected ranges
- ECOSYSTEM: < 2.6.10-1~ubuntu14.04.0~esm1
Update to 2.6.10-1~ubuntu14.04.0~esm1
wireshark Ubuntu:16.04:LTS
- Versions
- 1.12.7+g7fc8978-1
- 1.12.8+g5b6e543-2
- 2.0.1+g59ea380-3build1
- 2.0.2+ga16e22e-1
- 2.2.6+g32dac6a-2ubuntu0.16.04
- 2.6.3-1~ubuntu16.04.1
- 2.6.4-2~ubuntu16.04.0
- 2.6.5-1~ubuntu16.04.0
- 2.6.6-1~ubuntu16.04.0
- 2.6.8-1~ubuntu16.04.0
- Affected ranges
- ECOSYSTEM: < 2.6.10-1~ubuntu16.04.0
Update to 2.6.10-1~ubuntu16.04.0
wireshark Ubuntu:18.04:LTS
- Versions
- 2.4.2-1
- 2.4.3-1
- 2.4.4-1
- 2.4.5-1
- 2.6.3-1~ubuntu18.04.1
- 2.6.4-2~ubuntu18.04.0
- 2.6.5-1~ubuntu18.04.0
- 2.6.6-1~ubuntu18.04.0
- 2.6.8-1~ubuntu18.04.0
- Affected ranges
- ECOSYSTEM: < 2.6.10-1~ubuntu18.04.0
Update to 2.6.10-1~ubuntu18.04.0
Original sources
- https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=15870
- https://www.wireshark.org/security/wnpa-sec-2019-20.html
- https://code.wireshark.org/review/gitweb?p=wireshark.git%3Ba=commit%3Bh=7e90aed666e809c0db5de9d1816802a7dcea28d9
- http://www.securityfocus.com/bid/109293
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00068.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JY52XAC2UNC4X4ZPIXYMK5SVXV2PO5I3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/Q4QVJALLGVVC7MBUT4B4SHQVDXGJKGI7/
- https://usn.ubuntu.com/4133-1/
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00027.html
- https://lists.debian.org/debian-lts-announce/2021/02/msg00008.html
- https://nvd.nist.gov/vuln/detail/CVE-2019-13619