CVE-2019-14317
CVE-2019-14317
This page contains facts from public vulnerability sources. Check the original advisory before updating.
wolfSSL and wolfCrypt 4.1.0 and earlier (formerly known as CyaSSL) generate biased DSA nonces. This allows a remote attacker to compute the long term private key from several hundred DSA signatures via a lattice attack. The issue occurs because dsa.c fixes two bits of the generated nonces.
CVSS 5.3 · Medium · EPSS 1.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wolfssl Debian:12
- Affected ranges
- ECOSYSTEM: < 4.2.0+dfsg-1
Update to 4.2.0+dfsg-1
wolfssl Debian:13
- Affected ranges
- ECOSYSTEM: < 4.2.0+dfsg-1
Update to 4.2.0+dfsg-1
wolfssl Ubuntu:16.04:LTS
- Versions
- 3.4.8+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wolfssl Ubuntu:18.04:LTS
- Versions
- 3.10.2+dfsg-2
- 3.12.0+dfsg-1
- 3.12.2+dfsg-1
- 3.13.0+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published