p PatchFirst

CVE-2019-14513

CVE-2019-14513

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Improper bounds checking in Dnsmasq before 2.76 allows an attacker controlled DNS server to send large DNS packets that result in a read operation beyond the buffer allocated for the packet, a different vulnerability than CVE-2017-14491.

CVSS 7.5 · High · EPSS 1.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • dnsmasq Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.76-1

    Update to 2.76-1

  • dnsmasq Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.76-1

    Update to 2.76-1

  • dnsmasq Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.76-1

    Update to 2.76-1

  • dnsmasq Ubuntu:Pro:14.04:LTS

    Versions
    • 2.66-4ubuntu1
    • 2.67-1
    • 2.68-1
    • 2.68-1ubuntu0.1
    • 2.68-1ubuntu0.2
    • 2.68-1ubuntu0.2+esm1
    • 2.68-1ubuntu0.2+esm2
    • 2.68-1ubuntu0.2+esm3
    • 2.68-1ubuntu0.2+esm5
    • 2.68-1ubuntu0.2+esm6
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • dnsmasq Ubuntu:16.04:LTS

    Versions
    • 2.75-1
    • 2.75-1ubuntu0.16.04.1
    • 2.75-1ubuntu0.16.04.2
    • 2.75-1ubuntu0.16.04.3
    • 2.75-1ubuntu0.16.04.4
    • 2.75-1ubuntu0.16.04.5
    • 2.75-1ubuntu0.16.04.7
    • 2.75-1ubuntu0.16.04.8
    Affected ranges
    • ECOSYSTEM: < 2.75-1ubuntu0.16.04.10

    Update to 2.75-1ubuntu0.16.04.10

Original sources

Check your server →