p PatchFirst

CVE-2019-14833

CVE-2019-14833

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A flaw was found in Samba, all versions starting samba 4.5.0 before samba 4.9.15, samba 4.10.10, samba 4.11.2, in the way it handles a user password change or a new password for a samba user. The Samba Active Directory Domain Controller can be configured to use a custom script to check for password complexity. This configuration can fail to verify password complexity when non-ASCII characters are used in the password, which could lead to weak passwords being set for samba users, making it vulnerable to dictionary attacks.

CVSS 4.2 · Medium · EPSS 1.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • samba

    Versions
    • all versions starting samba 4.5.0 before samba 4.9.15, samba 4.10.10, samba 4.11.2: Affected

    No fix published

  • samba Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:4.11.1+dfsg-2

    Update to 2:4.11.1+dfsg-2

  • samba Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:4.11.1+dfsg-2

    Update to 2:4.11.1+dfsg-2

  • samba Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:4.11.1+dfsg-2

    Update to 2:4.11.1+dfsg-2

  • samba Ubuntu:18.04:LTS

    Versions
    • 2:4.6.7+dfsg-1ubuntu3
    • 2:4.7.1+dfsg-1ubuntu1
    • 2:4.7.3+dfsg-1ubuntu1
    • 2:4.7.4+dfsg-1ubuntu1
    • 2:4.7.6+dfsg~ubuntu-0ubuntu1
    • 2:4.7.6+dfsg~ubuntu-0ubuntu2
    • 2:4.7.6+dfsg~ubuntu-0ubuntu2.2
    • 2:4.7.6+dfsg~ubuntu-0ubuntu2.4
    • 2:4.7.6+dfsg~ubuntu-0ubuntu2.5
    • 2:4.7.6+dfsg~ubuntu-0ubuntu2.6
    • 2:4.7.6+dfsg~ubuntu-0ubuntu2.7
    • 2:4.7.6+dfsg~ubuntu-0ubuntu2.9
    • 2:4.7.6+dfsg~ubuntu-0ubuntu2.10
    • 2:4.7.6+dfsg~ubuntu-0ubuntu2.11
    Affected ranges
    • ECOSYSTEM: < 2:4.7.6+dfsg~ubuntu-0ubuntu2.13

    Update to 2:4.7.6+dfsg~ubuntu-0ubuntu2.13

Original sources

Check your server →