p PatchFirst

CVE-2019-14834

CVE-2019-14834

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability was found in dnsmasq before version 2.81, where the memory leak allows remote attackers to cause a denial of service (memory consumption) via vectors involving DHCP response creation.

CVSS 3.7 · Low · EPSS 2.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • dnsmasq

    Versions
    • before 2.81: Affected

    No fix published

  • dnsmasq Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.81-1

    Update to 2.81-1

  • dnsmasq Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.81-1

    Update to 2.81-1

  • dnsmasq Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.81-1

    Update to 2.81-1

  • dnsmasq Ubuntu:Pro:14.04:LTS

    Versions
    • 2.66-4ubuntu1
    • 2.67-1
    • 2.68-1
    • 2.68-1ubuntu0.1
    • 2.68-1ubuntu0.2
    • 2.68-1ubuntu0.2+esm1
    • 2.68-1ubuntu0.2+esm2
    Affected ranges
    • ECOSYSTEM: < 2.68-1ubuntu0.2+esm3

    Update to 2.68-1ubuntu0.2+esm3

  • dnsmasq Ubuntu:16.04:LTS

    Versions
    • 2.75-1
    • 2.75-1ubuntu0.16.04.1
    • 2.75-1ubuntu0.16.04.2
    • 2.75-1ubuntu0.16.04.3
    • 2.75-1ubuntu0.16.04.4
    • 2.75-1ubuntu0.16.04.5
    Affected ranges
    • ECOSYSTEM: < 2.75-1ubuntu0.16.04.7

    Update to 2.75-1ubuntu0.16.04.7

  • dnsmasq Ubuntu:18.04:LTS

    Versions
    • 2.78-1
    • 2.78-3
    • 2.79-1
    Affected ranges
    • ECOSYSTEM: < 2.79-1ubuntu0.2

    Update to 2.79-1ubuntu0.2

  • dnsmasq Ubuntu:20.04:LTS

    Versions
    • 2.80-1ubuntu2
    • 2.80-1ubuntu4
    • 2.80-1.1ubuntu1
    Affected ranges
    • ECOSYSTEM: < 2.80-1.1ubuntu1.2

    Update to 2.80-1.1ubuntu1.2

Original sources

Check your server →