p PatchFirst

CVE-2019-14856

CVE-2019-14856

This page contains facts from public vulnerability sources. Check the original advisory before updating.

ansible before versions 2.8.6, 2.7.14, 2.6.20 is vulnerable to a None

CVSS 6.4 · Medium · EPSS 1.7% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • ansible

    Versions
    • 2.8.6: Affected
    • 2.7.14: Affected
    • 2.6.20: Affected

    No fix published

  • ansible PyPI

    Versions
    • 2.8.0
    • 2.8.1
    • 2.8.2
    • 2.8.3
    • 2.8.4
    • 2.8.5
    Affected ranges
    • ECOSYSTEM: ≥ 2.8.0, < 2.8.6

    Update to 2.8.6

  • ansible PyPI

    Versions
    • 2.7.0
    • 2.7.1
    • 2.7.10
    • 2.7.11
    • 2.7.12
    • 2.7.13
    • 2.7.2
    • 2.7.3
    • 2.7.4
    • 2.7.5
    • 2.7.6
    • 2.7.7
    • 2.7.8
    • 2.7.9
    Affected ranges
    • ECOSYSTEM: ≥ 2.7.0, < 2.7.14

    Update to 2.7.14

  • ansible PyPI

    Versions
    • 2.6.0
    • 2.6.1
    • 2.6.10
    • 2.6.11
    • 2.6.12
    • 2.6.13
    • 2.6.14
    • 2.6.15
    • 2.6.16
    • 2.6.17
    • 2.6.18
    • 2.6.19
    • 2.6.2
    • 2.6.3
    • 2.6.4
    • 2.6.5
    • 2.6.6
    • 2.6.7
    • 2.6.8
    • 2.6.9
    Affected ranges
    • ECOSYSTEM: ≥ 2.6.0, < 2.6.20

    Update to 2.6.20

  • ansible PyPI

    Versions
    • 2.6.0
    • 2.6.1
    • 2.6.10
    • 2.6.11
    • 2.6.12
    • 2.6.13
    • 2.6.14
    • 2.6.15
    • 2.6.16
    • 2.6.17
    • 2.6.18
    • 2.6.19
    • 2.6.2
    • 2.6.3
    • 2.6.4
    • 2.6.5
    • 2.6.6
    • 2.6.7
    • 2.6.8
    • 2.6.9
    • 2.7.0
    • 2.7.1
    • 2.7.10
    • 2.7.11
    • 2.7.12
    • 2.7.13
    • 2.7.2
    • 2.7.3
    • 2.7.4
    • 2.7.5
    • 2.7.6
    • 2.7.7
    • 2.7.8
    • 2.7.9
    • 2.8.0
    • 2.8.1
    • 2.8.2
    • 2.8.3
    • 2.8.4
    • 2.8.5
    Affected ranges
    • ECOSYSTEM: ≥ 2.6.0, < 2.6.20 ∪ ≥ 2.7.0, < 2.7.14 ∪ ≥ 2.8.0, < 2.8.6

    Update to 2.6.20; Update to 2.7.14; Update to 2.8.6

Original sources

Check your server →