p PatchFirst

CVE-2019-14879

CVE-2019-14879

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability was found in Moodle versions 3.7.x before 3.7.3, 3.6.x before 3.6.7 and 3.5.x before 3.5.9. When a cohort role assignment was removed, the associated capabilities were not being revoked (where applicable).

CVSS 4.2 · Medium · EPSS 0.7% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • moodle

    Versions
    • 3.7.x before 3.7.3: Affected
    • 3.6.x before 3.6.7: Affected
    • 3.5.x before 3.5.9: Affected

    No fix published

  • moodle/moodle Packagist

    Versions
    • v3.7.0
    • v3.7.1
    • v3.7.2
    Affected ranges
    • ECOSYSTEM: ≥ 3.7.0, < 3.7.3

    Update to 3.7.3

  • moodle/moodle Packagist

    Versions
    • v3.6.0
    • v3.6.1
    • v3.6.2
    • v3.6.3
    • v3.6.4
    • v3.6.5
    • v3.6.6
    Affected ranges
    • ECOSYSTEM: ≥ 3.6.0, < 3.6.7

    Update to 3.6.7

  • moodle/moodle Packagist

    Versions
    • v3.5.0
    • v3.5.1
    • v3.5.2
    • v3.5.3
    • v3.5.4
    • v3.5.5
    • v3.5.6
    • v3.5.7
    • v3.5.8
    Affected ranges
    • ECOSYSTEM: ≥ 3.5.0, < 3.5.9

    Update to 3.5.9

  • moodle Ubuntu:Pro:16.04:LTS

    Versions
    • 2.7.9+dfsg-1
    • 2.7.10+dfsg-1
    • 2.7.11+dfsg-1
    • 2.7.11+dfsg-2
    • 2.7.12+dfsg-1
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • moodle Ubuntu:Pro:18.04:LTS

    Versions
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →