p PatchFirst

CVE-2019-14892

CVE-2019-14892

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A flaw was discovered in jackson-databind in versions before 2.9.10, 2.8.11.5 and 2.6.7.3, where it would permit polymorphic deserialization of a malicious object using commons-configuration 1 and 2 JNDI classes. An attacker could use this flaw to execute arbitrary code.

CVSS 7.5 · High · EPSS 5.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • jackson-databind

    Versions
    • Versions before 2.9.10: Affected
    • Versions before 2.8.11.5: Affected
    • Versions before 2.6.7.3: Affected

    No fix published

  • jackson-databind Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.10.0-1

    Update to 2.10.0-1

  • jackson-databind Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.10.0-1

    Update to 2.10.0-1

  • jackson-databind Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.10.0-1

    Update to 2.10.0-1

  • jackson-databind Ubuntu:Pro:14.04:LTS

    Versions
    • 2.2.2-1
    • 2.2.2-1ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • jackson-databind Ubuntu:18.04:LTS

    Versions
    • 2.8.6-1
    • 2.9.1-1
    • 2.9.4-1
    • 2.9.5-1
    • 2.9.8-1~18.04
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →