CVE-2019-14905
CVE-2019-14905
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability was found in Ansible Engine versions 2.9.x before 2.9.3, 2.8.x before 2.8.8, 2.7.x before 2.7.16 and earlier, where in Ansible's nxos_file_copy module can be used to copy files to a flash or bootflash on NXOS devices. Malicious code could craft the filename parameter to perform OS command injections. This could result in a loss of confidentiality of the system among other issues.
CVSS 7.3 · High · EPSS 0.7% · Fix available
- Published
- Updated
Affected products and versions
ansible
- Versions
- 2.9.x before 2.9.3: Affected
- 2.8.x before 2.8.8: Affected
- 2.7.x before 2.7.16: Affected
- 2.7.x and earlier: Affected
No fix published
ansible Debian:12
- Affected ranges
- ECOSYSTEM: < 2.9.4+dfsg-1
Update to 2.9.4+dfsg-1
ansible Debian:13
- Affected ranges
- ECOSYSTEM: < 2.9.4+dfsg-1
Update to 2.9.4+dfsg-1
ansible Debian:14
- Affected ranges
- ECOSYSTEM: < 2.9.4+dfsg-1
Update to 2.9.4+dfsg-1
ansible PyPI
- Versions
- 2.7.0
- 2.7.0a1
- 2.7.0b1
- 2.7.0rc1
- 2.7.0rc2
- 2.7.0rc3
- 2.7.0rc4
- 2.7.1
- 2.7.10
- 2.7.11
- 2.7.12
- 2.7.13
- 2.7.14
- 2.7.15
- 2.7.2
- 2.7.3
- 2.7.4
- 2.7.5
- 2.7.6
- 2.7.7
- 2.7.8
- 2.7.9
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0a1, < 2.7.16
Update to 2.7.16
ansible PyPI
- Versions
- 2.8.0
- 2.8.0a1
- 2.8.0b1
- 2.8.0rc1
- 2.8.0rc2
- 2.8.0rc3
- 2.8.1
- 2.8.2
- 2.8.3
- 2.8.4
- 2.8.5
- 2.8.6
- 2.8.7
- Affected ranges
- ECOSYSTEM: ≥ 2.8.0a1, < 2.8.8
Update to 2.8.8
ansible PyPI
- Versions
- 2.9.0
- 2.9.0b1
- 2.9.0rc1
- 2.9.0rc2
- 2.9.0rc3
- 2.9.0rc4
- 2.9.0rc5
- 2.9.1
- 2.9.2
- Affected ranges
- ECOSYSTEM: ≥ 2.9.0a1, < 2.9.3
Update to 2.9.3
ansible PyPI
- Versions
- 2.7.0
- 2.7.1
- 2.7.10
- 2.7.11
- 2.7.12
- 2.7.13
- 2.7.14
- 2.7.15
- 2.7.2
- 2.7.3
- 2.7.4
- 2.7.5
- 2.7.6
- 2.7.7
- 2.7.8
- 2.7.9
- 2.8.0
- 2.8.1
- 2.8.2
- 2.8.3
- 2.8.4
- 2.8.5
- 2.8.6
- 2.8.7
- 2.9.0
- 2.9.1
- 2.9.2
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.16 ∪ ≥ 2.8.0, < 2.8.8 ∪ ≥ 2.9.0, < 2.9.3
Update to 2.7.16; Update to 2.8.8; Update to 2.9.3
ansible Ubuntu:Pro:18.04:LTS
- Versions
- 2.3.1.0+dfsg-2
- 2.5.0+dfsg-1
- 2.5.1+dfsg-1
- 2.5.1+dfsg-1ubuntu0.1
- 2.5.1+dfsg-1ubuntu0.1+esm1
- 2.5.1+dfsg-1ubuntu0.1+esm2
- 2.5.1+dfsg-1ubuntu0.1+esm3
- 2.5.1+dfsg-1ubuntu0.1+esm4
- 2.5.1+dfsg-1ubuntu0.1+esm5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14905
- https://access.redhat.com/errata/RHSA-2020:0218
- https://access.redhat.com/errata/RHSA-2020:0216
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/5BNCYPQ4BY5QHBCJOAOPANB5FHATW2BR/
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html
- https://nvd.nist.gov/vuln/detail/CVE-2019-14905