p PatchFirst

CVE-2019-15531

CVE-2019-15531

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GNU Libextractor through 1.9 has a heap-based buffer over-read in the function EXTRACTOR_dvi_extract_method in plugins/dvi_extractor.c.

CVSS 6.5 · Medium · EPSS 1.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libextractor Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:1.9-2

    Update to 1:1.9-2

  • libextractor Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:1.9-2

    Update to 1:1.9-2

  • libextractor Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:1.9-2

    Update to 1:1.9-2

  • libextractor Ubuntu:Pro:14.04:LTS

    Versions
    • 1:1.1-1ubuntu1
    • 1:1.2-1ubuntu1
    • 1:1.3-1
    Affected ranges
    • ECOSYSTEM: < 1:1.3-1ubuntu0.1~esm1

    Update to 1:1.3-1ubuntu0.1~esm1

  • libextractor Ubuntu:16.04:LTS

    Versions
    • 1:1.3-2build1
    • 1:1.3-2ubuntu1
    • 1:1.3-3
    • 1:1.3-4+deb9u3build0.16.04.1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • libextractor Ubuntu:18.04:LTS

    Versions
    • 1:1.3-4build3
    • 1:1.6-1
    • 1:1.6-1build1
    • 1:1.6-2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →