p PatchFirst

CVE-2019-16780

CVE-2019-16780 · Stored cross-site scripting (XSS) in WordPress block editor

This page contains facts from public vulnerability sources. Check the original advisory before updating.

WordPress users with lower privileges (like contributors) can inject JavaScript code in the block editor using a specific payload, which is executed within the dashboard. This can lead to XSS if an admin opens the post in the editor. Execution of this attack does require an authenticated user. This has been patched in WordPress 5.3.1, along with all the previous WordPress versions from 3.7 to 5.3 via a minor release. Automatic updates are enabled by default for minor releases and we strongly recommend that you keep them enabled.

CVSS 5.8 · Medium · EPSS 1.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • wordpress

    Versions
    • ≥ < 5.3.1, < 5.3.1: Affected (custom)

    No fix published

  • wordpress Debian:12

    Affected ranges
    • ECOSYSTEM: < 5.3.2+dfsg1-1

    Update to 5.3.2+dfsg1-1

  • wordpress Debian:13

    Affected ranges
    • ECOSYSTEM: < 5.3.2+dfsg1-1

    Update to 5.3.2+dfsg1-1

  • wordpress Debian:14

    Affected ranges
    • ECOSYSTEM: < 5.3.2+dfsg1-1

    Update to 5.3.2+dfsg1-1

  • wordpress Ubuntu:16.04:LTS

    Versions
    • 4.3+dfsg-1
    • 4.3.1+dfsg-1
    • 4.4+dfsg-1
    • 4.4.1+dfsg-1
    • 4.4.2+dfsg-1
    • 4.4.2+dfsg-1ubuntu1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wordpress Ubuntu:18.04:LTS

    Versions
    • 4.8.2+dfsg-2
    • 4.8.3+dfsg-1
    • 4.9.1+dfsg-1
    • 4.9.2+dfsg-1
    • 4.9.4+dfsg-1
    • 4.9.5+dfsg1-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →