p PatchFirst

CVE-2019-16781

CVE-2019-16781 · Stored cross-site scripting (XSS) in WordPress block editor

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In WordPress before 5.3.1, authenticated users with lower privileges (like contributors) can inject JavaScript code in the block editor, which is executed within the dashboard. It can lead to an admin opening the affected post in the editor leading to XSS.

CVSS 5.8 · Medium · EPSS 1.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • wordpress

    Versions
    • ≥ < 5.3.1, < 5.3.1: Affected (custom)

    No fix published

  • wordpress Debian:12

    Affected ranges
    • ECOSYSTEM: < 5.3.2+dfsg1-1

    Update to 5.3.2+dfsg1-1

  • wordpress Debian:13

    Affected ranges
    • ECOSYSTEM: < 5.3.2+dfsg1-1

    Update to 5.3.2+dfsg1-1

  • wordpress Debian:14

    Affected ranges
    • ECOSYSTEM: < 5.3.2+dfsg1-1

    Update to 5.3.2+dfsg1-1

  • wordpress Ubuntu:16.04:LTS

    Versions
    • 4.3+dfsg-1
    • 4.3.1+dfsg-1
    • 4.4+dfsg-1
    • 4.4.1+dfsg-1
    • 4.4.2+dfsg-1
    • 4.4.2+dfsg-1ubuntu1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • wordpress Ubuntu:18.04:LTS

    Versions
    • 4.8.2+dfsg-2
    • 4.8.3+dfsg-1
    • 4.9.1+dfsg-1
    • 4.9.2+dfsg-1
    • 4.9.4+dfsg-1
    • 4.9.5+dfsg1-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →