CVE-2019-17006
CVE-2019-17006
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Network Security Services (NSS) before 3.46, several cryptographic primitives had missing length checks. In cases where the application calling the library did not perform a sanity check on the inputs it could result in a crash due to a buffer overflow.
CVSS 9.8 · Critical · EPSS 3.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
nss
- Versions
- ≥ unspecified, < 3.46: Affected (custom)
Update to 3.46
nss Debian:12
- Affected ranges
- ECOSYSTEM: < 2:3.47-1
Update to 2:3.47-1
nss Debian:13
- Affected ranges
- ECOSYSTEM: < 2:3.47-1
Update to 2:3.47-1
nss Debian:14
- Affected ranges
- ECOSYSTEM: < 2:3.47-1
Update to 2:3.47-1
nss Ubuntu:Pro:14.04:LTS
- Versions
- 2:3.15.1-1ubuntu1
- 2:3.15.2-1
- 2:3.15.3-1
- 2:3.15.3.1-1
- 2:3.15.3.1-1.1
- 2:3.15.3.1-1.1ubuntu1
- 2:3.15.4-1ubuntu3
- 2:3.15.4-1ubuntu4
- 2:3.15.4-1ubuntu5
- 2:3.15.4-1ubuntu6
- 2:3.15.4-1ubuntu7
- 2:3.15.4-1ubuntu7.1
- 2:3.17-0ubuntu0.14.04.1
- 2:3.17.1-0ubuntu0.14.04.1
- 2:3.17.1-0ubuntu0.14.04.2
- 2:3.17.4-0ubuntu0.14.04.1
- 2:3.19.2-0ubuntu0.14.04.1
- 2:3.19.2.1-0ubuntu0.14.04.1
- 2:3.19.2.1-0ubuntu0.14.04.2
- 2:3.21-0ubuntu0.14.04.1
- 2:3.21-0ubuntu0.14.04.2
- 2:3.23-0ubuntu0.14.04.1
- 2:3.26.2-0ubuntu0.14.04.3
- 2:3.28.4-0ubuntu0.14.04.1
- 2:3.28.4-0ubuntu0.14.04.2
- 2:3.28.4-0ubuntu0.14.04.3
- 2:3.28.4-0ubuntu0.14.04.4
- 2:3.28.4-0ubuntu0.14.04.5
- 2:3.28.4-0ubuntu0.14.04.5+esm1
- 2:3.28.4-0ubuntu0.14.04.5+esm2
- 2:3.28.4-0ubuntu0.14.04.5+esm3
- Affected ranges
- ECOSYSTEM: < 2:3.28.4-0ubuntu0.14.04.5+esm4
Update to 2:3.28.4-0ubuntu0.14.04.5+esm4
nss Ubuntu:16.04:LTS
- Versions
- 2:3.19.2-1ubuntu1
- 2:3.19.2.1-0ubuntu1
- 2:3.21-1ubuntu2
- 2:3.21-1ubuntu3
- 2:3.21-1ubuntu4
- 2:3.23-0ubuntu0.16.04.1
- 2:3.26.2-0ubuntu0.16.04.2
- 2:3.28.4-0ubuntu0.16.04.1
- 2:3.28.4-0ubuntu0.16.04.2
- 2:3.28.4-0ubuntu0.16.04.3
- 2:3.28.4-0ubuntu0.16.04.4
- 2:3.28.4-0ubuntu0.16.04.5
- 2:3.28.4-0ubuntu0.16.04.6
- 2:3.28.4-0ubuntu0.16.04.8
- 2:3.28.4-0ubuntu0.16.04.9
- Affected ranges
- ECOSYSTEM: < 2:3.28.4-0ubuntu0.16.04.10
Update to 2:3.28.4-0ubuntu0.16.04.10
nss Ubuntu:18.04:LTS
- Versions
- 2:3.32-1ubuntu3
- 2:3.34-1ubuntu1
- 2:3.35-2ubuntu2
- 2:3.35-2ubuntu2.1
- 2:3.35-2ubuntu2.2
- 2:3.35-2ubuntu2.3
- 2:3.35-2ubuntu2.5
- 2:3.35-2ubuntu2.6
- Affected ranges
- ECOSYSTEM: < 2:3.35-2ubuntu2.7
Update to 2:3.35-2ubuntu2.7
Original sources
- https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_3.46_release_notes
- https://bugzilla.mozilla.org/show_bug.cgi?id=1539788
- https://security.netapp.com/advisory/ntap-20210129-0001/
- https://cert-portal.siemens.com/productcert/pdf/ssa-379803.pdf
- https://us-cert.cisa.gov/ics/advisories/icsa-21-040-04
- https://nvd.nist.gov/vuln/detail/CVE-2019-17006