p PatchFirst

CVE-2019-17007

CVE-2019-17007

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In Network Security Services before 3.44, a malformed Netscape Certificate Sequence can cause NSS to crash, resulting in a denial of service.

CVSS 7.5 · High · EPSS 1.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • nss

    Versions
    • ≥ unspecified, < 3.44: Affected (custom)

    Update to 3.44

  • nss Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:3.45-1

    Update to 2:3.45-1

  • nss Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:3.45-1

    Update to 2:3.45-1

  • nss Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:3.45-1

    Update to 2:3.45-1

  • nss Ubuntu:Pro:14.04:LTS

    Versions
    • 2:3.15.1-1ubuntu1
    • 2:3.15.2-1
    • 2:3.15.3-1
    • 2:3.15.3.1-1
    • 2:3.15.3.1-1.1
    • 2:3.15.3.1-1.1ubuntu1
    • 2:3.15.4-1ubuntu3
    • 2:3.15.4-1ubuntu4
    • 2:3.15.4-1ubuntu5
    • 2:3.15.4-1ubuntu6
    • 2:3.15.4-1ubuntu7
    • 2:3.15.4-1ubuntu7.1
    • 2:3.17-0ubuntu0.14.04.1
    • 2:3.17.1-0ubuntu0.14.04.1
    • 2:3.17.1-0ubuntu0.14.04.2
    • 2:3.17.4-0ubuntu0.14.04.1
    • 2:3.19.2-0ubuntu0.14.04.1
    • 2:3.19.2.1-0ubuntu0.14.04.1
    • 2:3.19.2.1-0ubuntu0.14.04.2
    • 2:3.21-0ubuntu0.14.04.1
    • 2:3.21-0ubuntu0.14.04.2
    • 2:3.23-0ubuntu0.14.04.1
    • 2:3.26.2-0ubuntu0.14.04.3
    • 2:3.28.4-0ubuntu0.14.04.1
    • 2:3.28.4-0ubuntu0.14.04.2
    • 2:3.28.4-0ubuntu0.14.04.3
    • 2:3.28.4-0ubuntu0.14.04.4
    • 2:3.28.4-0ubuntu0.14.04.5
    • 2:3.28.4-0ubuntu0.14.04.5+esm1
    • 2:3.28.4-0ubuntu0.14.04.5+esm2
    Affected ranges
    • ECOSYSTEM: < 2:3.28.4-0ubuntu0.14.04.5+esm3

    Update to 2:3.28.4-0ubuntu0.14.04.5+esm3

  • nss Ubuntu:16.04:LTS

    Versions
    • 2:3.19.2-1ubuntu1
    • 2:3.19.2.1-0ubuntu1
    • 2:3.21-1ubuntu2
    • 2:3.21-1ubuntu3
    • 2:3.21-1ubuntu4
    • 2:3.23-0ubuntu0.16.04.1
    • 2:3.26.2-0ubuntu0.16.04.2
    • 2:3.28.4-0ubuntu0.16.04.1
    • 2:3.28.4-0ubuntu0.16.04.2
    • 2:3.28.4-0ubuntu0.16.04.3
    • 2:3.28.4-0ubuntu0.16.04.4
    • 2:3.28.4-0ubuntu0.16.04.5
    • 2:3.28.4-0ubuntu0.16.04.6
    • 2:3.28.4-0ubuntu0.16.04.8
    Affected ranges
    • ECOSYSTEM: < 2:3.28.4-0ubuntu0.16.04.9

    Update to 2:3.28.4-0ubuntu0.16.04.9

  • nss Ubuntu:18.04:LTS

    Versions
    • 2:3.32-1ubuntu3
    • 2:3.34-1ubuntu1
    • 2:3.35-2ubuntu2
    • 2:3.35-2ubuntu2.1
    • 2:3.35-2ubuntu2.2
    • 2:3.35-2ubuntu2.3
    • 2:3.35-2ubuntu2.5
    Affected ranges
    • ECOSYSTEM: < 2:3.35-2ubuntu2.6

    Update to 2:3.35-2ubuntu2.6

Original sources

Check your server →