p PatchFirst

CVE-2019-17358

CVE-2019-17358

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cacti through 1.2.7 is affected by multiple instances of lib/functions.php unsafe deserialization of user-controlled data to populate arrays. An authenticated attacker could use this to influence object data values and control actions taken by Cacti or potentially cause memory corruption in the PHP module.

CVSS 8.1 · High · EPSS 3.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • cacti Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.2.8+ds1-1

    Update to 1.2.8+ds1-1

  • cacti Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.2.8+ds1-1

    Update to 1.2.8+ds1-1

  • cacti Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.2.8+ds1-1

    Update to 1.2.8+ds1-1

  • cacti Ubuntu:Pro:14.04:LTS

    Versions
    • 0.8.8b+dfsg-3
    • 0.8.8b+dfsg-5
    • 0.8.8b+dfsg-5ubuntu0.1
    • 0.8.8b+dfsg-5ubuntu0.2
    Affected ranges
    • ECOSYSTEM: < 0.8.8b+dfsg-5ubuntu0.2+esm1

    Update to 0.8.8b+dfsg-5ubuntu0.2+esm1

  • cacti Ubuntu:Pro:16.04:LTS

    Versions
    • 0.8.8f+ds1-2
    • 0.8.8f+ds1-3
    • 0.8.8f+ds1-4
    • 0.8.8f+ds1-4ubuntu1
    • 0.8.8f+ds1-4ubuntu2
    • 0.8.8f+ds1-4ubuntu3
    • 0.8.8f+ds1-4ubuntu4
    • 0.8.8f+ds1-4ubuntu4.16.04
    • 0.8.8f+ds1-4ubuntu4.16.04.1
    • 0.8.8f+ds1-4ubuntu4.16.04.2
    • 0.8.8f+ds1-4ubuntu4.16.04.2+esm1
    • 0.8.8f+ds1-4ubuntu4.16.04.2+esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • cacti Ubuntu:Pro:18.04:LTS

    Versions
    • 1.1.18+ds1-1
    • 1.1.27+ds1-2
    • 1.1.27+ds1-3
    • 1.1.28+ds1-2
    • 1.1.35+ds1-1
    • 1.1.36+ds1-1
    • 1.1.38+ds1-1
    • 1.1.38+ds1-1ubuntu0.1~esm1
    • 1.1.38+ds1-1ubuntu0.1~esm3
    • 1.1.38+ds1-1ubuntu0.1~esm4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →