p PatchFirst

CVE-2019-17542

CVE-2019-17542

This page contains facts from public vulnerability sources. Check the original advisory before updating.

FFmpeg before 4.2 has a heap-based buffer overflow in vqa_decode_chunk because of an out-of-array access in vqa_decode_init in libavcodec/vqavideo.c.

CVSS 9.8 · Critical · EPSS 2.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ffmpeg Debian:12

    Affected ranges
    • ECOSYSTEM: < 7:4.2.1-1

    Update to 7:4.2.1-1

  • ffmpeg Debian:13

    Affected ranges
    • ECOSYSTEM: < 7:4.2.1-1

    Update to 7:4.2.1-1

  • ffmpeg Debian:14

    Affected ranges
    • ECOSYSTEM: < 7:4.2.1-1

    Update to 7:4.2.1-1

  • ffmpeg Ubuntu:16.04:LTS

    Versions
    • 7:2.7.2-1build1
    • 7:2.8.1-1ubuntu1
    • 7:2.8.2-1ubuntu1
    • 7:2.8.3-1
    • 7:2.8.4-1
    • 7:2.8.4-1ubuntu1
    • 7:2.8.4-1ubuntu2
    • 7:2.8.4-1ubuntu3
    • 7:2.8.4-1ubuntu4
    • 7:2.8.6-1ubuntu1
    • 7:2.8.6-1ubuntu2
    • 7:2.8.8-0ubuntu0.16.04.1
    • 7:2.8.10-0ubuntu0.16.04.1
    • 7:2.8.11-0ubuntu0.16.04.1
    • 7:2.8.14-0ubuntu0.16.04.1
    • 7:2.8.15-0ubuntu0.16.04.1
    Affected ranges
    • ECOSYSTEM: < 7:2.8.17-0ubuntu0.1

    Update to 7:2.8.17-0ubuntu0.1

  • ffmpeg Ubuntu:18.04:LTS

    Versions
    • 7:3.3.4-2
    • 7:3.3.4-2build3
    • 7:3.4-2ubuntu2
    • 7:3.4-4
    • 7:3.4-4build1
    • 7:3.4.1-1
    • 7:3.4.1-1build1
    • 7:3.4.2-1
    • 7:3.4.2-1build1
    • 7:3.4.2-2
    • 7:3.4.4-0ubuntu0.18.04.1
    • 7:3.4.6-0ubuntu0.18.04.1
    Affected ranges
    • ECOSYSTEM: < 7:3.4.8-0ubuntu0.2

    Update to 7:3.4.8-0ubuntu0.2

Original sources

Check your server →