CVE-2019-17673
CVE-2019-17673
This page contains facts from public vulnerability sources. Check the original advisory before updating.
WordPress before 5.2.4 is vulnerable to poisoning of the cache of JSON GET requests because certain requests lack a Vary: Origin header.
CVSS 7.5 · High · EPSS 3.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wordpress Debian:12
- Affected ranges
- ECOSYSTEM: < 5.2.4+dfsg1-1
Update to 5.2.4+dfsg1-1
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 5.2.4+dfsg1-1
Update to 5.2.4+dfsg1-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 5.2.4+dfsg1-1
Update to 5.2.4+dfsg1-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:18.04:LTS
- Versions
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://wpvulndb.com/vulnerabilities/9911
- https://blog.wpscan.org/wordpress/security/release/2019/10/15/wordpress-524-security-release-breakdown.html
- https://wordpress.org/news/2019/10/wordpress-5-2-4-security-release/
- https://core.trac.wordpress.org/changeset/46478
- https://github.com/WordPress/WordPress/commit/b224c251adfa16a5f84074a3c0886270c9df38de
- https://seclists.org/bugtraq/2020/Jan/8
- https://www.debian.org/security/2020/dsa-4599
- https://www.debian.org/security/2020/dsa-4677
- https://nvd.nist.gov/vuln/detail/CVE-2019-17673