CVE-2019-1787
CVE-2019-1787 · Clam AntiVirus PDF Denial of Service Vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability in the Portable Document Format (PDF) scanning functionality of Clam AntiVirus (ClamAV) Software versions 0.101.1 and prior could allow an unauthenticated, remote attacker to cause a denial of service (DoS) condition on an affected device. The vulnerability is due to a lack of proper data handling mechanisms within the device buffer while indexing remaining file data on an affected device. An attacker could exploit this vulnerability by sending crafted PDF files to an affected device. A successful exploit could allow the attacker to cause a heap buffer out-of-bounds read condition, resulting in a crash that could result in a denial of service condition on an affected device.
CVSS 7.5 · High · EPSS 1.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
clamav
- Versions
- 0.101.1: Affected
No fix published
clamav Debian:12
- Affected ranges
- ECOSYSTEM: < 0.101.2+dfsg-1
Update to 0.101.2+dfsg-1
clamav Debian:13
- Affected ranges
- ECOSYSTEM: < 0.101.2+dfsg-1
Update to 0.101.2+dfsg-1
clamav Debian:14
- Affected ranges
- ECOSYSTEM: < 0.101.2+dfsg-1
Update to 0.101.2+dfsg-1
clamav Ubuntu:14.04:LTS
- Versions
- 0.97.8+dfsg-1ubuntu4
- 0.97.8+dfsg-1ubuntu5
- 0.98.1+dfsg-1ubuntu4
- 0.98.1+dfsg-1ubuntu5
- 0.98.1+dfsg-2ubuntu2
- 0.98.1+dfsg-4ubuntu1
- 0.98.1+dfsg-4ubuntu1.1
- 0.98.5+addedllvm-0ubuntu0.14.04.1
- 0.98.6+dfsg-0ubuntu0.14.04.1
- 0.98.7+dfsg-0ubuntu0.14.04.1
- 0.99.2+addedllvm-0ubuntu0.14.04.1
- 0.99.2+addedllvm-0ubuntu0.14.04.2
- 0.99.3+addedllvm-0ubuntu0.14.04.1
- 0.99.4+addedllvm-0ubuntu0.14.04.1
- 0.100.1+dfsg-1ubuntu0.14.04.1
- 0.100.1+dfsg-1ubuntu0.14.04.2
- 0.100.1+dfsg-1ubuntu0.14.04.3
- 0.100.1+dfsg-1ubuntu0.14.04.4
- 0.100.2+dfsg-1ubuntu0.14.04.1
- 0.100.2+dfsg-1ubuntu0.14.04.2
- Affected ranges
- ECOSYSTEM: < 0.100.3+dfsg-0ubuntu0.14.04.1
Update to 0.100.3+dfsg-0ubuntu0.14.04.1
clamav Ubuntu:16.04:LTS
- Versions
- 0.98.7+dfsg-0ubuntu4
- 0.98.7+dfsg-0ubuntu5
- 0.99+dfsg-1ubuntu1
- 0.99+dfsg-1ubuntu1.1
- 0.99+dfsg-1ubuntu1.2
- 0.99.2+dfsg-0ubuntu0.16.04.1
- 0.99.2+dfsg-0ubuntu0.16.04.2
- 0.99.2+dfsg-0ubuntu0.16.04.3
- 0.99.3+addedllvm-0ubuntu0.16.04.1
- 0.99.4+addedllvm-0ubuntu0.16.04.1
- 0.100.1+dfsg-1ubuntu0.16.04.1
- 0.100.1+dfsg-1ubuntu0.16.04.2
- 0.100.1+dfsg-1ubuntu0.16.04.3
- 0.100.2+dfsg-1ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 0.100.3+dfsg-0ubuntu0.16.04.1
Update to 0.100.3+dfsg-0ubuntu0.16.04.1
clamav Ubuntu:18.04:LTS
- Versions
- 0.99.2+dfsg-6ubuntu2
- 0.99.3~beta1+dfsg-2ubuntu1
- 0.99.3~beta1+dfsg-2ubuntu2
- 0.99.3+addedllvm-0ubuntu1
- 0.99.3+addedllvm-0ubuntu2
- 0.99.4+addedllvm-0ubuntu1
- 0.100.1+dfsg-1ubuntu0.18.04.1
- 0.100.1+dfsg-1ubuntu0.18.04.2
- 0.100.1+dfsg-1ubuntu0.18.04.3
- 0.100.2+dfsg-1ubuntu0.18.04.1
- Affected ranges
- ECOSYSTEM: < 0.100.3+dfsg-0ubuntu0.18.04.1
Update to 0.100.3+dfsg-0ubuntu0.18.04.1
Original sources
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=12181
- https://security.gentoo.org/glsa/201904-12
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00064.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00062.html
- https://lists.debian.org/debian-lts-announce/2019/04/msg00019.html
- https://nvd.nist.gov/vuln/detail/CVE-2019-1787