p PatchFirst

CVE-2019-18934

CVE-2019-18934

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Unbound 1.6.4 through 1.9.4 contain a vulnerability in the ipsec module that can cause shell code execution after receiving a specially crafted answer. This issue can only be triggered if unbound was compiled with `--enable-ipsecmod` support, and ipsecmod is enabled and used in the configuration.

CVSS 7.3 · High · EPSS 3.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • unbound Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.9.6-1

    Update to 1.9.6-1

  • unbound Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.9.6-1

    Update to 1.9.6-1

  • unbound Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.9.6-1

    Update to 1.9.6-1

Original sources

Check your server →