CVE-2019-19246
CVE-2019-19246
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Oniguruma through 6.9.3, as used in PHP 7.3.x and other products, has a heap-based buffer over-read in str_lower_case_match in regexec.c.
CVSS 7.5 · High · EPSS 3.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
libonig Debian:12
- Affected ranges
- ECOSYSTEM: < 6.9.4-1
Update to 6.9.4-1
libonig Debian:13
- Affected ranges
- ECOSYSTEM: < 6.9.4-1
Update to 6.9.4-1
libonig Debian:14
- Affected ranges
- ECOSYSTEM: < 6.9.4-1
Update to 6.9.4-1
libonig Ubuntu:Pro:14.04:LTS
- Versions
- 5.9.1-1
- 5.9.1-1ubuntu1
- 5.9.1-1ubuntu1.1
- 5.9.1-1ubuntu1.1+esm1
- Affected ranges
- ECOSYSTEM: < 5.9.1-1ubuntu1.1+esm2
Update to 5.9.1-1ubuntu1.1+esm2
libonig Ubuntu:Pro:16.04:LTS
- Versions
- 5.9.6-1
- 5.9.6-1ubuntu0.1
- 5.9.6-1ubuntu0.1+esm1
- Affected ranges
- ECOSYSTEM: < 5.9.6-1ubuntu0.1+esm2
Update to 5.9.6-1ubuntu0.1+esm2
libonig Ubuntu:Pro:18.04:LTS
- Versions
- 6.5.0-1
- 6.6.1-1
- 6.7.0-1
- 6.7.0-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: < 6.7.0-1ubuntu0.1~esm2
Update to 6.7.0-1ubuntu0.1~esm2
Original sources
- https://github.com/kkos/oniguruma/commit/d3e402928b6eb3327f8f7d59a9edfa622fec557b
- https://bugs.php.net/bug.php?id=78559
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NO267PLHGYZSWX3XTRPKYBKD4J3YOU5V/
- https://lists.debian.org/debian-lts-announce/2019/12/msg00002.html
- https://usn.ubuntu.com/4460-1/
- https://nvd.nist.gov/vuln/detail/CVE-2019-19246