p PatchFirst

CVE-2019-19604

CVE-2019-19604

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Arbitrary command execution is possible in Git before 2.20.2, 2.21.x before 2.21.1, 2.22.x before 2.22.2, 2.23.x before 2.23.1, and 2.24.x before 2.24.1 because a "git submodule update" operation can run commands found in the .gitmodules file of a malicious repository.

CVSS 7.8 · High · EPSS 3.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • git Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:2.24.0-2

    Update to 1:2.24.0-2

  • git Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:2.24.0-2

    Update to 1:2.24.0-2

  • git Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:2.24.0-2

    Update to 1:2.24.0-2

Original sources

Check your server →