p PatchFirst

CVE-2019-19637

CVE-2019-19637

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was discovered in libsixel 1.8.2. There is an integer overflow in the function sixel_decode_raw_impl at fromsixel.c.

CVSS 9.8 · Critical · EPSS 1.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libsixel Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.8.6-1

    Update to 1.8.6-1

  • libsixel Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.8.6-1

    Update to 1.8.6-1

  • libsixel Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.8.6-1

    Update to 1.8.6-1

  • libsixel Ubuntu:16.04:LTS

    Versions
    • 1.4.2-1
    • 1.5.2-2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • libsixel Ubuntu:18.04:LTS

    Versions
    • 1.5.2-2
    • 1.7.3-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • libsixel Ubuntu:20.04:LTS

    Versions
    • 1.8.2-1
    • 1.8.2-2.1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →