CVE-2019-20041
CVE-2019-20041
This page contains facts from public vulnerability sources. Check the original advisory before updating.
wp_kses_bad_protocol in wp-includes/kses.php in WordPress before 5.3.1 mishandles the HTML5 colon named entity, allowing attackers to bypass input sanitization, as demonstrated by the javascript: substring.
CVSS 9.8 · Critical · EPSS 4.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wordpress Debian:12
- Affected ranges
- ECOSYSTEM: < 5.3.2+dfsg1-1
Update to 5.3.2+dfsg1-1
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 5.3.2+dfsg1-1
Update to 5.3.2+dfsg1-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 5.3.2+dfsg1-1
Update to 5.3.2+dfsg1-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:18.04:LTS
- Versions
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/
- https://github.com/WordPress/wordpress-develop/commit/b1975463dd995da19bb40d3fa0786498717e3c53
- https://seclists.org/bugtraq/2020/Jan/8
- https://www.debian.org/security/2020/dsa-4599
- https://lists.debian.org/debian-lts-announce/2020/01/msg00010.html
- https://www.debian.org/security/2020/dsa-4677
- https://nvd.nist.gov/vuln/detail/CVE-2019-20041