p PatchFirst

CVE-2019-20444

CVE-2019-20444

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

HttpObjectDecoder.java in Netty before 4.1.44 allows an HTTP header that lacks a colon, which might be interpreted as a separate header with an incorrect syntax, or might be interpreted as an "invalid fold."

CVSS 9.1 · Critical · EPSS 8.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • netty Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:4.1.45-1

    Update to 1:4.1.45-1

  • netty Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:4.1.45-1

    Update to 1:4.1.45-1

  • netty Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:4.1.45-1

    Update to 1:4.1.45-1

  • netty Ubuntu:Pro:14.04:LTS

    Versions
    • 1:3.2.6.Final-2
    Affected ranges
    • ECOSYSTEM: < 1:3.2.6.Final-2+deb8u2build0.14.04.1~esm1

    Update to 1:3.2.6.Final-2+deb8u2build0.14.04.1~esm1

  • netty-3.9 Ubuntu:16.04:LTS

    Versions
    • 3.9.0.Final-1
    Affected ranges
    • ECOSYSTEM: < 3.9.0.Final-1ubuntu0.1

    Update to 3.9.0.Final-1ubuntu0.1

  • netty Ubuntu:Pro:16.04:LTS

    Versions
    • 1:3.2.6.Final-2
    • 1:4.0.32-1
    • 1:4.0.33-1
    • 1:4.0.34-1
    • 1:4.0.34-1ubuntu0.1~esm1
    • 1:4.0.34-1ubuntu0.1~esm2
    • 1:4.0.34-1ubuntu0.1~esm3
    • 1:4.0.34-1ubuntu0.1~esm4
    • 1:4.0.34-1ubuntu0.1~esm5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • netty Ubuntu:18.04:LTS

    Versions
    • 1:4.1.7-4
    Affected ranges
    • ECOSYSTEM: < 1:4.1.7-4ubuntu0.1

    Update to 1:4.1.7-4ubuntu0.1

  • netty-3.9 Ubuntu:18.04:LTS

    Versions
    • 3.9.9.Final-1
    Affected ranges
    • ECOSYSTEM: < 3.9.9.Final-1+deb9u1build0.18.04.1

    Update to 3.9.9.Final-1+deb9u1build0.18.04.1

Original sources

Check your server →