CVE-2019-20631
CVE-2019-20631
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue was discovered in libgpac.a in GPAC before 0.8.0, as demonstrated by MP4Box. It contains an invalid pointer dereference in gf_list_count in utils/list.c that can cause a denial of service via a crafted MP4 file.
CVSS 5.5 · Medium · EPSS 0.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
gpac Debian:11
- Affected ranges
- ECOSYSTEM: < 1.0.1+dfsg1-2
Update to 1.0.1+dfsg1-2
gpac Ubuntu:Pro:14.04:LTS
- Versions
- 0.5.0+svn4288~dfsg1-1ubuntu1
- 0.5.0+svn4288~dfsg1-4
- 0.5.0+svn4288~dfsg1-4ubuntu1
- 0.5.0+svn4288~dfsg1-4ubuntu1+esm1
- 0.5.0+svn4288~dfsg1-4ubuntu1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gpac Ubuntu:Pro:16.04:LTS
- Versions
- 0.5.2-426-gc5ad4e4+dfsg5-1build1
- 0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1
- 0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gpac Ubuntu:Pro:18.04:LTS
- Versions
- 0.5.2-426-gc5ad4e4+dfsg5-3
- 0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1
- 0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gpac Ubuntu:Pro:20.04:LTS
- Versions
- 0.5.2-426-gc5ad4e4+dfsg5-4ubuntu1
- 0.5.2-426-gc5ad4e4+dfsg5-5
- 0.5.2-426-gc5ad4e4+dfsg5-5ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published